Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > All over the road!!

Join Wrangler Forum Today


Thread: All over the road!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-22-2012 06:52 PM
Soli Deo Gloria Ok busy weekend so I just finished up this project today. My sway bar end links had a lot of slop and play - I upgraded to the Taraflex quick disconnect (Nice, but not as easy of install as they claim) but not the end of the world. I also upgraded my steering linkage to the heavy duty from quadratec which also had heavy duty tie rod ends.
After all this I took it for a spin and it was night and day. There was still a little sway and wobble - so I checked the tire pressure. You were correct it was high. So I put it to the correct pressure.
I still need to change my U-joint (didn't get to that) there is still a noticeable difference there. And I need to straighten my steering wheel.

Jerry - I added the pics to my profile because I can't figure out how to get one on the posting, so if you could take a look and let me know that would be great!

Thanks for any input its a blessing!
10-19-2012 10:16 AM
Soli Deo Gloria This is a great place to start! I will upload some pictures either today or tomorrow so let you see what I have going on. I believe the control arms are stock.

I will check and adjust the tire pressure accordingly, and check the toe-in.

I will post pictures with an update and let you know how this goes. THanks so much for the starting point!!
10-19-2012 09:39 AM
Jerry Bransford First, have the toe-in checked & adjusted if required. Next, is there a dropped Pitman arm installed? If you don't know, take a picture & post it here and we can tell you. A dropped Pitman arm can cause bump steer which is when the steering forces the Jeep left/right in response to bumps/dips in the road. If the bump steer is bad enough, that can even happen as you accelerate/deaccelerate.

Next, are you control arms aftermarket and do they have an adjustable length? If they do, it's possible your front axle's caster angle is bad from their lengths not being set properly... likely insufficient caster angle if their length is incorrectly set. If your arms are the factory arms, your caster angle is likely ok.

Finally, if the control arms are adjustable length, make sure both axles are square in terms of to the chassis and to each other. When control arm lengths are adjustable, there are a lot of ways a clueless installer can jack things up.

Finally, make sure your tire pressures are all the same. And exactly what tire pressure is in them? For 35x12.50 tires, 24-26 psi at the most is correct. I am betting they are overinflated at this point.

Here's a pic of the front-end that shows the Pitman arm. If you post a pic of yours here, take the picture so it shows the angle like in this photo. You can click on it to make it bigger.
10-19-2012 09:17 AM
Tjdude08 Id say if you haven't installed those sway bar links thats part of it
10-19-2012 08:53 AM
Soli Deo Gloria
All over the road!!

Howdy,
I am new to this forum and I have had jeeps for quite a few years and just bought a 2001 Jeep Wrangler 4.0

This is how I bought it: 4" lift / 35" Tires
I put new shocks - Rancho 5000 on it
and a new steering stabalizer - Moog
and just bought heavy duty steering linkage - going to put it on this weekend.

My sway bars links were junk so I just bought taraflex disconnects - hopefully I can get them on this weekend as well

I was checking things out underneight and found a lot of slop in the U-joints so bought some new to put on as well.

I do not do a lot of off roading but would like to get into it at the beginner level becuase I don't have a ton to put into it. But it is a beast to keep on the road is swerves back and forth and even when I let of the gas it will pull one way or the other.

I was wondering if anyone had any ideas? I will let you know the difference It makes after these few upgrades, but I didn't know if with the lift the lack of adustable track bars could be doing this. Any help would be much appretiated! THanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:33 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC