Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > after changing car battery radio won't work

Join Wrangler Forum Today


Thread: after changing car battery radio won't work Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-28-2012 10:30 AM
Iceman My apologies there is a us box there In a tj, didn't realize you were working on a jk. If you have a test light or multimeter c yo contest for voltage at the radio wiring connector. With the jeep on you should have 2 pos 12 volt wires.
10-28-2012 12:38 AM
zagu im starting to think the head unit (radio) is the one that is busted but i want to make sure also... tho i dont know why it happened without the fuse being busted...
10-28-2012 12:07 AM
zagu i opened my glove box and remove "it" check inside i dont see any fuse or anything. i took pictures i will post it also so you guys could see and help me.
i have a 2010 jeep wrangler JK (unlimited rubicon)

im really frustrated already having no sounds for the past 3-4 months is killing me









10-27-2012 07:41 AM
Iceman The fuse box behind the glove box is "open." Open the glove now and remove it (slide the retaining strap out and lift the GB out.) The fuse box is mounted to the firewall behind th glove box amid has no cover.
10-27-2012 04:01 AM
zagu how do i open the fuse box behind the glove box? any idea? thanks been searching the net and cant find anything about it
10-26-2012 02:49 PM
eboven There are multiple fuses that will affect the power to the radio. Check each individual fuse in the Jeep just to be sure - one fusebox behind the glovebox, and one under the hood in front of the battery.
10-26-2012 02:27 AM
zagu anyone can help me on this. checked the fuse using a tester and its all good... as for the wiring how do i check if a wire got disconnected? i never touch any wires tho. Thanks
09-29-2012 10:13 PM
Dianeakamommy What was the problem? I had mine jumped at my kids school and now nothing. Fuses where also fine.
07-05-2012 10:41 AM
bbtj You might also want to check and make sure that there aren't any other fuses, such as an in-line fuse.
07-04-2012 04:27 PM
bbtj The only other thing I got is to check the wiring, make sure it is all connected properly.
07-04-2012 10:28 AM
zagu okay just checked the fuse M10 (15amp) no problem whatsoever the contacts are still in place.

any other ideas?
07-02-2012 10:42 AM
zagu I'm thinking fuse also...

now the next thing would be how do i get to the fuse box this is so hard... haha

as for wires on the battery i did not remove any other wire except the positive/negative to change the battery other than that did not do anything else.
07-02-2012 07:48 AM
jefferyfghezzi Is there a wire that was left off thr battery?
07-02-2012 07:34 AM
bbtj check the fuses is the only thing I can think of.
07-02-2012 12:22 AM
zagu
after changing car battery radio won't work

Since my stock battery gave out on me i had no choice but to change. After changing everything seems well except for the radio headunit. It wont turn on. Any idea? Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC