Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 2.5L dies while driving

Join Wrangler Forum Today


Thread: 2.5L dies while driving Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-25-2008 09:28 PM
87YJWrangler Mine was the little intersection thing next to the battery tray by the engine I had to replace a few connectors and it worked fine, idk maybe try that
12-25-2008 06:58 PM
jpdocdave sounds like a fuel pump. only way to know is test fuel pressure when it won't start. and then check power at the pump. otherwise you're just guessing. good luck
12-25-2008 04:35 PM
Jeep'rs
2.5L dies while driving

Had the same problem year or so ago. Changed my fuel pump relay, problem remained. Changed the fuel filter and fuel pump. It has ran very well since. Ended up being the fuel pump.


Good Luck
12-24-2008 06:47 AM
scrambler1 try the "ford wiggle test" while it is idling go around and wiggle the wiring harness and connections until you find the problem do the same around the fuel pump harness. goodluck
12-24-2008 06:06 AM
spazinweasel clean the tb and look for loose connections if that dont help look for a bad ground or a short if that isnt it you may be looking at a computer good luck
12-23-2008 11:56 PM
zfender14
2.5L dies while driving

I have begun having an issue with the jeep dying while I drive down the road. I will just be going along as normal and the it dies... The lights and hazards, radio all still work fine though. I will pull over and wait a few seconds to a minute and it will start up again. I go a little farther and repeat what I just described. So far its been intermittent, but today it happened maybe five times within 20 miles of interstate driving and with traffic seems like this problem is now a safety hazard. I replaced the distributer coil this afternoon and since then it has happened twice this evening. Anyone have any ideas? I am at a loss, thought the coil would fix the problem but apparently it hasn't.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC