Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Just installed 2" lift

Join Wrangler Forum Today


Thread: Just installed 2" lift Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-30-2010 07:25 PM
cbsarefun i just installed a 2" lift in my 06 Rubicon. Imediately it started clunking in the rear. It was a shock going bad. I replaced my shocks with skyjacker hydro 7000 for the 2" lift and it is just FANTASTIC now!
08-11-2010 10:08 PM
Wildkarde A for effort XJ, but its been five years so i hope the hell he has figured it out by now lol
08-11-2010 09:59 PM
XJSean Check trac bar mount at body, I had metal fatigue and upgrading to heavier duty mount/trac bar from rock krawler took care of a similar problem/sound
04-23-2005 11:22 AM
4Jeepn Still popping eh? Get a pal take turns walking next to the Jeep as one of you starts to move it forward enough to make the pop sound. See if you can figure the exact spot where the sound is coming from. At this point I am sure you have checked a ton of stuff but here is a short list of things I would look at: Also does it just pop once or many times?
Drive shaft u-joints front and rear?
Do you need a t-case lowering kit perhaps?
Bad motor mount?
Bad tranny mount?
Axle u-joint?
Is the rear track bar hitting something. gas tank skid.
That's all I can think of for now.. again keep us posted!
04-23-2005 11:08 AM
wgreiner I checked all bolts and they are tight. I tried grease to all fittings. Any other suggestions
04-18-2005 02:18 PM
JeepCrawler98 Sounds good - be sure to let us all know how it goes
04-18-2005 09:21 AM
wgreiner Thanks for the ideas I will check all bolts today.
04-17-2005 01:37 PM
4Jeepn You may also want to check to make sure the springs are seated correctly. Most likely though its a loose bolt some place. Good Luck!
04-17-2005 11:51 AM
JeepCrawler98 Yeah - tighten the heck out of that one, and check all the other ones again and again, just because it didn't click before doesn't mean it was tight properly either, when you lift it you increase stress and leverage on bolts and what not so stuff's going to move around more.
04-16-2005 10:22 PM
1BLKJP That is what is call the Trac Bar. You most definitely need to make sure that is tight also or you will start having more problems than just a popping noise. The trac bar keeps your axle located under the center of your jeep and an improperly functioning trac bar will cause Death Woble.
04-16-2005 09:12 PM
wgreiner Sound is coming from the front not sure which side though. All I took loose was the shocks on the front, and on the rear I took the shocks and the bar that runs from the frame to the axle beside the shock mounts.
04-16-2005 12:20 AM
JeepnTX I'm with him...when I did my spacers, I got the popping also. One of my LCA's was loose by about 15 ft lbs.
04-16-2005 12:04 AM
JeepCrawler98 Where is this pop coming from? left, right, front, rear? I'd start by checking the torque on all the nuts and bolts - remember if you loosened up the control arms at all, they require a LOT of torque for proper tightening.
04-15-2005 09:02 PM
wgreiner
Just installed 2" lift

I just installed a 2" suspension lift on my 97 TJ now it is making a popping noise when I start out from a stop. I left everything stock and just added the 2" rubber spacers. Any ideas on what to check or how to fix this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:45 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC