Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Coolant leak with Check engine light on

Join Wrangler Forum Today


Thread: Coolant leak with Check engine light on Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-20-2012 03:38 PM
UnlimitedRubicon
Quote:
Originally Posted by Sarah325 View Post
Well I had some people check it out, they pressurized it and said there aren't any leaks any where. This would point to the water pump, correct?

I can't say for sure but my pump wasn't leaking when the engine was running as far as I recall. I would leak after shutdown and while cooling down.


Quote:
Originally Posted by Sarah325 View Post
They also said my check engine light was on because it was "running rich". Is there a fix for that?

The P0138 code you had was "1/2 O2 Sensor Shorted To Voltage - Oxygen sensor input voltage maintained above normal operating range". See this page: OBD2 - OBDII Code P0138 JEEP - O2 sensor 1/2 Circuit high | Engine-Codes.com
11-20-2012 02:51 PM
jkp The error code indicates an issue with one of the O2 sensors that is below the converter. Probably just the sensor, but could also be a bad converter.
11-19-2012 04:44 PM
Sarah325 Well I had some people check it out, they pressurized it and said there aren't any leaks any where. This would point to the water pump, correct? They also said my check engine light was on because it was "running rich". Is there a fix for that?
11-18-2012 02:00 PM
UnlimitedRubicon
Quote:
Originally Posted by Sarah325 View Post
I don't see any water coming out, I'll have to check it next time I notice it leaking.

Try warming it up to operating temp. Wait a half hour or better and check again.


Quote:
Originally Posted by Sarah325 View Post
Thanks for the info, it could end up being very useful if that's what the problem is!

No problem.
11-18-2012 01:54 PM
Sarah325 I don't see any water coming out, I'll have to check it next time I notice it leaking. Thanks for the info, it could end up being very useful if that's what the problem is!
11-18-2012 01:27 PM
UnlimitedRubicon
Quote:
Originally Posted by Sarah325 View Post
So, weird thing. I went to go check it out today, and I couldn't determine where it was leaking from, so I went to autozone with it to see if they could help. I get there, and it's not leaking anymore! It's been pretty cold here and just warmed up today, could the cold be doing something? And if it was the water pump, would it just stop?

I had a leak that would only happen when cooling down. It was the water pump and I had it replaced under warranty. It could have something to do with thermal expansion preventing the leakage but as the engine/water cools it allows the leakage. You can look up between the pulley and the block and see if you have water coming from the weep hole.

Here's a link from 4x4xplor.com that has some pics: waterpump
11-18-2012 12:02 PM
Sarah325 So, weird thing. I went to go check it out today, and I couldn't determine where it was leaking from, so I went to autozone with it to see if they could help. I get there, and it's not leaking anymore! It's been pretty cold here and just warmed up today, could the cold be doing something? And if it was the water pump, would it just stop?
11-17-2012 11:09 PM
jkp They should not be related. The O2 sensor is on the exhaust manifold and is used by the computer.

The coolant leak is probably the water pump, but could be a hose or the thermostat housing as mentioned above.
11-17-2012 10:52 PM
Sarah325 Thanks guys, I got the codes thing to work. It came up at P0138, it's saying the O2 sensor. Could these two things be totally unrelated? It seems weird that they would occur at exactly the same time..
11-17-2012 10:15 PM
jkp You can read the codes out by putting your key in the ignition and turning it: On, Off, On, Off, On. Do not go to the start position, just the on position. The codes will show up in the odometer. You can look them up here: Tech - TJ Error Codes - GETAHELMET.COM
11-17-2012 10:04 PM
tangofox007 The water pump would be a prime suspect for a leak in that location. Could also be the thermostat housing or an associated hose. You just need to get a pair of eyes in there and look.

The coolant loss is not a direct cause of the check engine light. You need to read the code(s). Depending on year model, you might be able to do that without a code reader.
11-17-2012 08:06 PM
Sarah325
Coolant leak with Check engine light on

I recently had my alignment fixed on my jeep. Right after my check engine light was on and I discovered a huge coolant leak. My reservoir was almost completely empty and I haven't been over heating or anything. It only happens once the Jeep has warmed up. I attached pictures I found on another thread that shows exactly where my coolant is leaking from. I'm going to take a better look at it tomorrow, but if anyone has an idea what the problem could be...I found a lot of people saying water pump but any ideas would be appreciated. Thanks!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC