Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > intermittant dash/gauges ???? 99 TJ

Join Wrangler Forum Today


Thread: intermittant dash/gauges ???? 99 TJ Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-20-2012 10:42 AM
Bucktaker
Quote:
Originally Posted by bardb View Post

Thanks man thats what I needed...
11-20-2012 10:41 AM
Bucktaker
Quote:
Originally Posted by TexasTJ3016 View Post
Behind the instrument cluster. You will have to remove the instrument cluster to get to the connectors. Send me a PM with your email and I'll send you the directions.

Thanks Tex... the link below your post has them included......seems easy enough

Might read over the led thread since Im pulling the cluster

Thanks again all this is a great resource.......
11-20-2012 06:45 AM
bardb TJ Jeep Problem with Instrument Guages.
11-19-2012 08:16 PM
TexasTJ3016 Behind the instrument cluster. You will have to remove the instrument cluster to get to the connectors. Send me a PM with your email and I'll send you the directions.
11-19-2012 07:43 PM
Bucktaker I forgot its a jeep thing lol...... just bang it

Ok where is the connector you are talking about? under the dash or behind the instruments cluster?
11-19-2012 11:16 AM
Doublebarr
Quote:
Originally Posted by TexasTJ3016 View Post
As a temporary quick fix/diagnostic tool, you can try emergency repair procedure #1. Give the top of the dash a solid wrap with your hand. If the dash works after that then see above.
LOLOL! This is EXACTLY what I did and it worked. So I got in there and did the quick clean and bend trick too
11-19-2012 11:14 AM
TexasTJ3016 As a temporary quick fix/diagnostic tool, you can try emergency repair procedure #1. Give the top of the dash a solid wrap with your hand. If the dash works after that then see above.
11-19-2012 11:11 AM
TexasTJ3016 Same problem on my 2000. Fixed it by removing the Instrument Cluster, cleaned the contacts and bent them slightly to make better connection.
11-19-2012 11:03 AM
Bucktaker
intermittant dash/gauges ???? 99 TJ

My new to me 99 TJ has a intermittant problem with the dash. Sometimes on startup the dash comes on as normal and goes thru its light check then I have no dash indicators and the airbag light is on. Once restarting the vehicle cured it then today it acted up and I drove it 10 miles to town to the parts store (rear diff seal) it never worked and I racked up no miles on the trip odo.
Got parts and started home the dash came on normally but while driving home I saw it flash off .....then came back on. where should I look for a loose or bad connection?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:39 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC