Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Instr Panel lights - ground issue?

Join Wrangler Forum Today


Thread: Instr Panel lights - ground issue? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-22-2012 11:54 PM
theshers
Well heck

Good news, bad news....

After discovering that the rear running lights weren't working (front running and all blinkers worked - didn't think about checking rear running), my younger son could wait to research further and pulled the #1 fuse. It was fried. Replace the fuse and everything works.

Bad news? Well we pulled the dash back off and did all kinds of troubleshooting and online searching - only to find out it was a fuse! We had checked one fuse but not the one that counted!

Oh well - valuable lesson learned. And my son got the glory, so he goes to bed tonight with a feeling of accomplishment.
11-22-2012 08:30 AM
theshers
Yep - tried that

Read through some posts and it seems you're not the only one to go through that Sort of like when I installed the KC Hilites and buttoned it up - one light didn't work. Helps if you connect all the quick connects

I've found a good quality switch for under $20. I'll try that and post results. But if anyone else has any ideas - feel free to share.
11-21-2012 11:25 PM
29JeepTJ09 My first guess would be a bad ground. Not totally sure about that though.

When I pulled my dash off a while back I accidentally turned the headlight switch to the right dimming my dash lights nearly all the way. In all the years of owning my Jeep I had never realized that it even had a way to dim the lights. I spent days trying to figure out the problem only to find I twisted the dimmer down. Sorry don't mean to hijack just thought it was kinda funny.
11-21-2012 11:08 PM
theshers Although I tested yesterday and lights worked, still unable to get the instrum panel to light up. Pulled off dash and reinstalled, pulled out stereo. If I pull the light switch partially out - just before parking lights turn on - I get dash lights. All the way out - no go. Thinking ground or bad rheostat.

Thoughts?
11-21-2012 08:17 PM
theshers
Instr Panel lights - ground issue?

Removed dash to run some wires for new KC Hilites. Re-installed and all worked good. Sons pulled back off a couple times to replace a stereo and nw we have no dash lights. Blinkers and low gas lights work. Any suggestions?

BTW - have used this forum for years and never had to post. Wealth of information here. Thanks for all your posts.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC