Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > brights work, low beams don't

Join Wrangler Forum Today


Thread: brights work, low beams don't Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-30-2012 11:12 PM
WranglerX2003
Quote:
Originally Posted by Jerry Bransford View Post
Yep most likely the switch. However, just last week a guy did the obvious & replaced his switch & discovered after that that both of his low beams had simply burned out. I would suspect the switch myself too but I'd do a continuity test across the low beam bulb filaments first just to verify that they are indeed still good before buying a new switch.
Alright il try that before I spend the 40 bucks on the new switch
11-30-2012 05:57 PM
tallzdatank
Quote:
Originally Posted by Jerry Bransford View Post
Yep most likely the switch. However, just last week a guy did the obvious & replaced his switch & discovered after that that both of his low beams had simply burned out. I would suspect the switch myself too but I'd do a continuity test across the low beam bulb filaments first just to verify that they are indeed still good before buying a new switch.
or put a test light to the power wire going to the low beams, if no power, then its the switch.
11-30-2012 05:41 PM
Jerry Bransford Yep most likely the switch. However, just last week a guy did the obvious & replaced his switch & discovered after that that both of his low beams had simply burned out. I would suspect the switch myself too but I'd do a continuity test across the low beam bulb filaments first just to verify that they are indeed still good before buying a new switch.
11-30-2012 03:29 PM
WranglerX2003 Alrighty il check it out, thanks for your help
11-30-2012 03:24 PM
tallzdatank yessir that'd be my guess if your fuses are all good. first check to see that power is coming into the switch, then try turning your lights on, if no power coming out then the switch is bad.
11-30-2012 03:17 PM
WranglerX2003
Quote:
Originally Posted by tallzdatank View Post
switch.
Replace the entire switch assembly?
11-30-2012 03:11 PM
tallzdatank switch.
11-30-2012 03:10 PM
WranglerX2003
brights work, low beams don't

Hey guys n gals so the other day my headlights cut out while driving and now just the brights work? I checked all the fuses and everything looked good any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:44 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC