Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum > 81 CJ front Hubs.

Join Wrangler Forum Today


Thread: 81 CJ front Hubs. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-16-2012 05:13 PM
RubiconRich warn 6 bolt Premium hubs are the best!
12-10-2012 05:34 PM
harleydragon cool..I have used mile marker with no problems but you can get a bad one in anything.I'm sure he will love the warns
12-10-2012 04:18 PM
rykemc
Quote:
Originally Posted by harleydragon View Post
take it apart and see what the problem is

I have. Several times. When we first built his jeep we had problems with the one hub. Right side hub. It would never lock in right. Normal operation is you can feel the hub hit the "lock" in either free or locked position. This hub never did that so you could actually go past the locked position then it was screwed and had to be taken back apart and clocked right. Tired of missing with the POS. This is going to be dad's Christmas gift from us kids.
12-07-2012 08:49 PM
harleydragon take it apart and see what the problem is
12-07-2012 08:37 PM
RubiconRich warn hubs all the way
12-07-2012 01:57 PM
rykemc
81 CJ front Hubs.

Bought some Mile Marker locking hubs for dad's 81 CJ. Not real happy with them though. The passenger side hub if you don't engage it just right it will get out of "time" and not work. Over Thanksgiving weekend we were out wheeling and it just didnt seem like the front was locking in completely. I did try to turn the axle at the hub and it felt like it was engaged but just did not pull with the front axles.

Anyone ever run these hubs? I am leaning toward them not being a very good product and maybe I should go ahead and order the Warn hubs for his Christmas present.

Thoughts?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:55 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC