Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum > 2400 miles on new jk having trans problem

Join Wrangler Forum Today


Thread: 2400 miles on new jk having trans problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-14-2009 01:03 AM
jk'n This is one of the reasons I like standards. Much less to go wrong with it. Chrysler usually reserves major repairs to difficult to solve problems. If they repaired the transmission and it is showing no signs of the original problem, they would call that fixed. Of course there is customer satisfaction involved too. I wonder how much noise you would have to make to get them to replace the transmission. I think it would be more likely to happen if the problem resurfaces.
01-12-2009 05:21 PM
bgjhnsn 2007 JK, 31K miles, dealer replaced entire tranny. Wouldn't go into reverse. Hope your 08 has the lifetime powertrain warranty. If Chrysler isn't broke, they will be soon, fixing all these tranny's.
01-07-2009 08:35 AM
kbart Not yet, but on start up in morning I sure do get a lot of what sounds like valve chatter.
01-06-2009 05:40 PM
Hitchhiker
Quote:
Ticked off because this is a new vehicle.
I would be too, hope it turns out to be OK and was just a fluke failure.

Regards,
Richard
01-06-2009 05:23 PM
NTJeep
2400 miles on new jk having trans problem

I have a new 2008 JK with 2400 miles and had to have a valve body and torque converter replaced. The check engine light came on an the diagnostics pointed to the transmission. The transmission shifted fine. I would not have even noticed a problem if the check engine light had not come on. The vehicle has NEVER been stressed, I haven't had a chance to take it off road. The dealer has no idea of what might have caused the problem other than the torque converter coming apart. They said that they found metal pieces in the valve body.

The dealer said this was not a common problem; replacing the torque converter and valve body would solve the problem.

Has anyone out there had a similar problem? Any idea of what may have caused the problem?

Would you be comfortable with the replacement of the valve body and torque converter or would you replace the transmission?

Ticked off because this is a new vehicle.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC