Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > electrical problem? shuts off while driving

Join Wrangler Forum Today


Thread: electrical problem? shuts off while driving Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-29-2013 12:06 PM
wi11ys05 Thanks! Now on to my other problems, I started a new thread for that though haha
01-29-2013 12:01 PM
General Confusion Good to hear you finally got it sorted.
01-29-2013 11:56 AM
wi11ys05 to update this thread, the problem has been fixed. I ended up getting a brand new OEM PCM installed by the dealer. Much more expensive than the bobo brands, but I had used another PCM from autozone that did not work. I had the dealer install it because otherwise it would have voided the warranty on the PCM. It definitely fixed the problem, the only way for me to decide it was the cause was to absolutely eliminate everything else.
01-23-2013 05:48 PM
zeprider25
Quote:
Originally Posted by Surinamer View Post
My problem turned out to be a loose wire.
Yeah what wire I'm having same issues
01-23-2013 04:45 PM
4xMike Glad you got it squared away! What wire was loose?
01-23-2013 04:33 PM
Surinamer My problem turned out to be a loose wire.
12-15-2012 11:10 AM
wi11ys05 Just thought I would add a small update, and maybe stir the hypothetical pot here. I have ordered a new PCM, but in the meantime I will continue to search for a definite answer. The problem is still consistently intermittent, and if I am unlucky enough to be at a stoplight when it happens then i have to turn it on and off a few times to get it running properly. Usually. However, if I am driving, let's say 5th gear, rpm's are good, and it happens... dash lights flicker, rpm's bog down to 0, I have noticed a loud clicking from the rear of the jeep. I drop it down a gear, keep the accelerator floored, and the engine will usually kick back on. I know that may make it sound like it's not getting air or fuel, but again- they have been checked. fuel pressure is good, especially with the new fuel pump.
12-10-2012 02:34 PM
Jerry Bransford
Quote:
Originally Posted by General Confusion View Post
I think the OP said he had already replaced the CPS. Bowing to your greater knowledge Jerry, but that's why I didn't suggest it.
Oops you are right. I must be blind, I missed that even though I specifically looked for that information
12-10-2012 02:21 PM
General Confusion I think the OP said he had already replaced the CPS. Bowing to your greater knowledge Jerry, but that's why I didn't suggest it.
12-10-2012 02:15 PM
Jerry Bransford That same exact symptom often happens when the engine's Crankshaft Position Sensor goes bad... at least when it is just the engine that suddenly dies and nothing else shuts off. The CPS is what provides the engine's master timing signal so when it goes bad, and they do, the engine will suddenly stall.

The CPS is located up high on the driver's side where the transmission bolts to the engine block
12-10-2012 02:14 PM
General Confusion OK.

This may not be the answer, but many years ago I had a similar problem on one of my Dad's cars.

After much searching and changing of parts, I finally decided to strip the fuel tank out. When I emptied the tank out, there was a large dead bee in there. It must have flown in while he was fueling or something.

What was happening was that at random intervals, the bee would get sucked across the end of the fuel line and block it. When the engine stopped and the fuel pump stopped pulling fuel, the offending dead insect would float away into the tank again and everything would be fine until the next time.

It's a long shot I know, but it seems you have tried everything else.
12-10-2012 01:51 PM
wi11ys05 There have been a few updates since I first posted this, but the problem has not been fixed yet unfortunately. I decided to bite the bullet and had a local shop fix it. I gave them a list of all parts I replaced. After over a month of having my jeep, and replacing some parts that I already did, they still could not find the problem. They simply told me they "suspected it's the PCM." Well I already suspected that as well. Found a great link on another forum-

Crash Course In Brain Surgery Replacing Capacitors On ECU - JeepForum.com

So I figured if my PCM is bad, why not try it anyway? I removed the PCM, opened it up and replaced the capacitors. Jeep worked great for about a week. Then the problem started back up. No idea if what I did actually fixed the problem or not.

In response to the comments above, from top to bottom-
Surinamer- I would like to replace my PCM, but I cant justify spending the money yet if I don't know that it will actually fix the problem.
JeepnJim- I have a manual transmission, so there is no neutral safety switch.
Off Pavement- Unfortunately, none of the mounting holes for the PCM are used as a ground in my '05, and all grounds have been checked.
dmblair- The fuel pump relay has been checked and is good. If I am driving and the jeep shuts off, it is just the engine. When I go to start it back up, electronics work fine, but the engine won't start. At this point it will crank, and usually after cranking it several times it will start. And then die, rpm's stay very low when this happens. When the problem acts up, this happens 4 or 5 times in just a few miles of driving. Then the jeep will drive fine for the next few days or so!
harleydragon- I have had this happen at all speeds, which is what worries me. Doing 60mph on a highway and then all of a sudden losing power steering is not a good thing.

I would like to put in a new PCM, but as the problem is intermittent, I have no way of knowing if it would actually be fixed or not. If its a fuel or spark problem, I would think that the jeep wouldnt run fine for a week or so and then have the problem occur again.
12-09-2012 10:19 AM
harleydragon had this happen to my 91 yj,just once so far..running about 60 and it just quit.coasted for about 20 seconds and it took off again.runs great otherwise.mine is 4.0,auto..will be very interested to see your outcome
12-09-2012 10:10 AM
dmblair IIRC isn't there a relay for the fuel pump? Have you checked around that area at all?? Possibly a relay is failing and killing the fuel supply? When it shuts off, do lose power to everything? Such as interior lights, dash lights, headlights etc., or does the engine just die and everything electrical is still ok??
12-09-2012 09:59 AM
Off Pavement Not sure if the newer TJs have the same PCM as a '97, but one of the mounting holes for the PCM is used as the PCM ground to the body. If I remember correctly, it's the top right attachment as you look towards the firewall. My '97 had a loose ground that required a new mounting screw. It caused all sorts of intermittent problems until I finally found it.
12-09-2012 09:25 AM
JeepnJim Describes exactly what my Cherokee did and it was the neutral safety switch which was attatched to the side of the transmission I think. I had also replaced the starter and plugs and what not before I finally tracked down the culprit. Good Luck.
12-09-2012 08:02 AM
Surinamer
What was the resolution?

I've got something similar - think I need to replace the PCM.
09-29-2012 10:43 AM
wi11ys05
electrical problem? shuts off while driving

I'll try to cover the basics of what has been done, but if you have any questions or need me to clarify, please let me know. I have read multiple threads with people having a similar issue, but everything I've tried has not worked so far.
I have a 2005 wrangler, willys edition. 4.0L, standard transmission. Approximately 63,000 miles on it. While I am driving, no matter the speed, the jeep will just shut off. When it first started it occurred rarely, now it happens every time I drive it. I used to be able to turn the ignition off and it would start right back up. Now I have to pull over and continuously try to start it. It will almost always turn on right away, but with almost zero rpms, and it just sputters out, almost like there is no fuel. Eventually it will fire up normally and away I go. When this happens, the fuel gauge drops to empty, even on a full tank, and the check engine light comes on. There are no error codes, Ive even had a shop hook up the computer while this happened and nothing popped up. The dealership looked at it and couldn't find anything wrong with it, as it is an "intermittent problem." Since this started happening, I have put in a new crankshaft position sensor, camshaft position sensor, and a new fuel pump assembly. I have also cleaned the IAC, the whole throttle body actually. I also put a new starter in it about two months ago as well. The only thing I can think of is that is an electrical problem, possibly with the pcm. I have a multi-meter, and have been testing different wires, so far everything I have checked is good to go. Any input would be greatly appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC