Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Help new Wrangler Unlimited Sahara 2012 owner

Join Wrangler Forum Today


Thread: Help new Wrangler Unlimited Sahara 2012 owner Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-12-2012 09:37 PM
wcbardwell I wish you luck... I have a 2012 JKUS in Bright Silver... I am not sure what you are talking about, but I'm pretty sure I don't have the symptoms you are describing. You're on the right track by taking it to the dealer... Let them fix it on their dime and save yourself the trouble of worrying.
12-12-2012 08:47 PM
Martijt2
Help new Wrangler Unlimited Sahara 2012 owner

Well. After many years of wanting a Jeep Wrangler finally pulled the trigger this week and purchased, last night, a 2012 Unlimited. Drove home about 50 miles away no problem. Drove to work this morning no problem. On the drive home, now just over 200 miles on the ODO and getting strange driveline or bearing noise that's pretty loud and then goes away. Frustrating. Realize warranty will cover anything but wondering if anyone here had a similar low mileage issue.
It's not brakes. And seems to be louder when turning but it's off and on. I will take it to a dealer for check out but sure not a great way to start the Jeep experience. It was built in June 2012 and therefore has mostly sat for 6 months.

Thanks for thoughts. I can't yet find the power steering refill to make sure fluid isn't the problem as it could be a cavitation noise. I just can't tell yet where the source of the noise is coming from.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:52 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC