Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Oil pump sending unit

Join Wrangler Forum Today


Thread: Oil pump sending unit Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-13-2006 06:23 PM
R.P.M.
Oil Pump Sending Unit

Mine is a 93 4banger and when we replaced the sending unit it had ruptured and was leaking oil all over the side of the block.
It was that way when we bought it. That took some time to track down as the oil PSI gauge stood at zero. We did have to
buy a special deep well socket with a notch to remove and reinstall the sending unit. Replaced with an aftermarket unit that worked about 3 months, now idels at 40 psi and pegs at speed. Local 4WD shop suggested replacing with oem unit. Thats on the to do list, BUT Ill check the actual oil PSI with a test gauge just to be sure of actual PSI at idle and reved.
Hope this helps
11-13-2006 06:18 PM
donald Thanks I will go out there tomarrow and look to see if that is were mine is.
11-13-2006 07:55 AM
amara8 I have a 91 wrangler with a 4.0 engine.
Mine is on the lower right side of the engine in front of the the oil filter.
11-11-2006 07:04 PM
donald
Oil pump sending unit

I need help locating my oil pump sending unit I think I found it but want to make sure anyone help?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:01 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC