Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > battery gauge

Join Wrangler Forum Today


Thread: battery gauge Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-28-2012 04:31 PM
tjjeep95 It was the alternator
12-19-2012 03:39 PM
sparky
Quote:
Originally Posted by tjjeep95 View Post
Battery was in it when i bought it in June nothing with the other gauges and it starts fine just all of sudden started happening terminals are tight and clean
Battery should have a date on top of it. Older than 5 years it's suspect.
Pull those terminal connections anyway and clean them. It's the first step, and it costs nothing.

Next step is to have the battery and alternator load tested by your local auto store.
12-19-2012 11:40 AM
MosesTJ I had a similar problem except the truck would shutdown on me while stopped. Thinking the worst, I took the battery to get tested and decided to remake the cable ends with new terminals and 6months later no trouble. I actually bought the terminal wire brush. The corrosion was under the connector and I could not tell. Good luck.
12-19-2012 11:24 AM
Wrangler40L Check for loose wires; alt, ground wire to frame, etc.
12-19-2012 09:04 AM
tjjeep95 Battery was in it when i bought it in June nothing with the other gauges and it starts fine just all of sudden started happening terminals are tight and clean
12-19-2012 09:01 AM
sparky How old is the battery? Do any other gauges ack funny?

Could be battery, could be alternator. First thing, take off and clean your battery connections, when replaced make sure they are tight.
12-19-2012 08:50 AM
tjjeep95
battery gauge

98 sport 4.0 Jeep starts up fine after running for a few minutes Check gauges light comes on and battery gauge drops to zero shut off the Jeep and the lights go off after 10 minutes same thing happens again is it a short or the battery on its way out thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC