Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 2000 tj clutch issue?

Join Wrangler Forum Today


Thread: 2000 tj clutch issue? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-22-2012 03:59 PM
Tjkid8
Quote:
Originally Posted by Wattapunk
Do you have any shifting issues or noises when engaging the clutch? Have you tried giving it enough gas while slowly releasing the clutch?
No shifting or noises but I shifted into 2 twice and it grinder gears with the clutch in all the way and yes I know how to drive a stick I even had my rpm to 3500 and let off slow and it still did it idk if it's the clutch but it looks like it
12-22-2012 03:52 PM
Wattapunk Do you have any shifting issues or noises when engaging the clutch? Have you tried giving it enough gas while slowly releasing the clutch?
12-22-2012 03:39 PM
Tjkid8
2000 tj clutch issue?

My 2000 tj 4.0 l6 5 speed manual is riding un usual. Whenever starting from a complete stop I'm getting a bad vibration ( like when you don't give it enough gas and wants to stall and it bogs) I don't know if it is the pressure plate or bad slave cylinder or if just the clutch is going. don't know what it is maybe you guys can give me some help

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC