Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Did Jeep Ever get a Fix

Join Wrangler Forum Today


Thread: Did Jeep Ever get a Fix Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-28-2013 01:02 PM
tomthbomb My 2012 is right on. Maybe syncing with my RAZR Maxx via Bluetooth or the maybe with the GPS?
01-28-2013 12:53 PM
MaskMan Fixed my 130 slow time issue....

With a new 2013 730n radio...
01-28-2013 11:51 AM
J33P3RS Like many of you apparently, I though it was just me. All the sudden I would notice 2 min slow & fix, then maybe 3-4, etc. Guess pro-cal should have added clock calibration in with speedo calibration.
01-28-2013 11:40 AM
2five22 Does anyone have a fast clock in their Wrangler?
01-28-2013 11:35 AM
Strokerswild Jesus motor.....
01-28-2013 08:11 AM
JEEPDON Here I thought the Jesus motor; the fantastic Pantistar; would make everything go faster!!!!. I guess I was wrong!
01-28-2013 07:58 AM
WXman The TSB is out now. It's TSB # 08-003-13.

It involves replacing the WCM/SKREEM module.

It applies to 2009-2012 JK and KK models.
01-04-2013 06:48 AM
WXman The fact that Chrysler is saying a flash is coming to fix this issue leads me to think that the problem does not lie within the head unit itself. The problem apparently is in the computer module that powers the head unit or something like that. Low voltage feed making the clock run slow. So in theory, it doesn't matter which head unit you install it'll be the same problem.

What aggravates me is that most of the guages are wrong. The ambient temp. is way off (was like this on my '11 also, and I'm a weather guy so I know how to test for this), the speedometer was wrong from the factory (verified by GPS), the clock won't keep time, the buttons on the wheel are finicky and you have to hit them a lot to cycle through the settings, the avg. MPG display is always wrong and won't even work at all if you try to reset it while moving, etc. etc. It's like Chrysler doesn't have a clue how to calibrate an instrument. We paid for these features whether we wanted to or not...least they could do is take the time to make them accurate.
01-03-2013 07:18 PM
Ivoryring I am sure I am going to jynx it - but my 130 w/ Sirius didn't drift at all since I got it in August... but I'm pulling the radio out to replace with Pioneer aftermarket so it won't matter if I'm temping the clock gods!
01-03-2013 04:47 PM
1quick1 Mine is slow.
01-03-2013 04:44 PM
Peter T Glad I am not the only one having to fix the clock every time I get in when it has been sitting for a couple of days. I don't understand. I would have thought the radio would have a 12volt wire live to keep the clock up to date.
01-03-2013 01:56 PM
Mr. Fish My 2012 with 130 loses about 1min every 2 weeks. Not a huge deal to reset it, but kinda silly that it's an issue at all.
01-03-2013 08:11 AM
jcj2121 Do they all do this or just a lucky few?
01-03-2013 07:33 AM
lee indy i fix mine every couple weeks.

agreed pathetic
01-03-2013 06:20 AM
Strokerswild Mine loses 2-3 minutes per week.

In the 8.5 years I owned my '04 F150 I never had to reset the minutes on the clock, just the hours when it came to daylight savings time.

Pathetic if you ask me.
01-02-2013 07:10 PM
DJL2 Mine also loses time...and it annoys my wife quite a lot. Honestly, it's sort of embarrassing. I can get a five dollar wrist watch that keeps better time - surely, someone over at Jeep/Chrysler can reverse engineer a Casio wrist watch and crack the code on decent time keeping. When it was Daimler-Chrysler did it occur to no one that it might be worth asking how it is they manage to keep time in their cars?

Just sort of sad...
01-02-2013 07:03 PM
WXman As of today (2-January-2013) my dealership says the flash is still not available and is "in process".
12-26-2012 02:32 PM
285 HP Yep a min or two every two weeks...let me know if you found a fix for it.
12-26-2012 12:05 PM
Raziel They are working on it last I heard which was a few months ago. They replace the module for it twice & then found out chrysler is working on it. Haven't found any info for a fix it
12-26-2012 10:10 AM
res1971 I was wondering why my clock was over 30 minutes slow when I got back last week from A-stan. I thought someone set it to that time zone or something sine they are set on a 30 minute difference time..
12-26-2012 09:57 AM
kappaknight For those of you with the problem, do you have the 130 radio? I have the 430N and it hasn't been an issue after about a month. I assume the ones with satellite and nav are okay?
12-26-2012 09:07 AM
WXman there's lots of threads on this. yes, there is a flash available according to the dealerships. some guys have gotten it done already. mine is going in any day now.
12-26-2012 08:58 AM
JTPhoto JK Daughters 09 is out a couple minutes a month. Wife has the same unit in her 10 Caravan, set it and forget it.
12-26-2012 07:59 AM
Strokerswild I have to reset monthly also.....
12-25-2012 12:34 PM
nwbronco I'm with WatchThis. We have 3. Set 'em and forget 'em. Y'all are allowing the GPS to control the time...right?


Bob K.
12-25-2012 12:26 PM
WatchThis! I find it funny that my clock has never missed a beat. Still the same as it was the last time I reset it after the duel battery install............
12-25-2012 09:17 AM
Rufus T. Firefly
Quote:
Originally Posted by NYC View Post
For the slow clock in the 2012's.
Any new software?
I had the same problem in 2000. What makes you think they'd fix it now? It also happens in my 2010. I adjust it every couple weeks.
12-25-2012 09:16 AM
Harleyrider1108 I keep thinking I'm on time for work.
12-25-2012 09:14 AM
4DoorCrush Mine loses about 5 mins a months
12-25-2012 08:09 AM
j66996 Mine loses time too
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:15 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC