Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 2012 poor fuel mileage

Join Wrangler Forum Today


Thread: 2012 poor fuel mileage Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-02-2013 12:57 PM
Holly84 Just so u all know... I informed Chrysler canada about the head issue and if enough people call them and not the dealerships they will do a recall so start calling... There number is 1 (800) 465-2001 good luck
01-01-2013 07:29 PM
Holly84
Quote:
Originally Posted by Con Artist

Did you already trade it in? If not, find another dealership who may be a little more willing to help you out. I'd also fire back with all these "mishaps" they've caused, especially with Chrysler's customer service department.
Hey I went in yesterday to trade it in.. I went to both Chrysler dealerships here and neither one can figure it out.. and the nearest other one is 4hrs away lol and I'm only getting 200kms to a tank of fuel so it's not really worth it to pay for fuel and hotels.. And I also called Chrysler canada and try didn't do anything either.. But in the future we will Definately buy another one
01-01-2013 06:05 PM
MikeK46 Are the defective heads linked to fuel economy issues?

I thought ticking, misfire & CEL light....

Never heard of it causing a fuel economy drop, is that another symptom?

If so, then people without excessive ticking or CEL lights may be living with poor fuel economy without knowing they have a bad head. Now that is f*cked up and makes me wonder about my own fuel economy, which is 13.5mpg despite me driving like a grandma.
01-01-2013 04:49 PM
Mikulas OP, can you name the dealer? I notice you are in Canada.
Is it possible to have a "Shame the Dealer" or "Recomended Dealer" sticky thread, or would that violate the forum etiquete? I would trust the opinion of forum members more than a google search.
01-01-2013 02:56 PM
Numbercruncher
Quote:
Originally Posted by smitty141 View Post
I bought a 2013 in November. What would be a easy way to tell if my Jeep may have the old head??

Thanks
http://www.wranglerforum.com/f33/doe...ad-198794.html

Scroll down and you will find the answer.

NC
01-01-2013 01:20 PM
Garyk
Quote:
Originally Posted by Holly84 View Post
Just wanted to say thank you for all your comments as to what could be wrong with my jeep.. With all the crappy service I have gotten and with them still not having a clue what there doing (had it in the shop for a coolant leak.. It came out with coolant cap still open, no engine cover, and a clunk on the drivers side ) we have decided to trade it in.. It was a nice vehicle but not worth all the stupidity.. Hopefully in the future we can purchase another one
Its a damn shame that a crappy dealer can ruin the experience of owning a Jeep....If you have traded it, I would certainly let Chrysler know why you did...
01-01-2013 01:20 PM
smitty141 I bought a 2013 in November. What would be a easy way to tell if my Jeep may have the old head??

Thanks
01-01-2013 01:12 PM
Txrdstr [ATTACH]193225[/AT

Julian date calander
01-01-2013 01:09 PM
Txrdstr
Quote:
Originally Posted by Numbercruncher

I have followed the bad head as closely as I can and I thought the holy grail was the julian build week. If you see the build number and it is greater than 2062 you were safe. 206 is the week built and the final two is for model year 2012. Based on this and not hearing about needing a build number that has a 3 for model year 2013 I had hoped all the 2013's were fine. Am I wrong in this assumption?

NC
The Julian build date is day, not week, but you are correct 2062 ( July 26, 2012) 206th day of the year. Seems to be the general consensus of the cut off for the AA head that seems to be problematic. The 13 model years are not going to have a 3 on the build date untill the actual head is built in 2013 for example my 13 hs a head build date 2822 ( 282nd say of 2012 , oct 9.). Don't know if many 13 have the head because seems like not a large back supply in manufacturing , but there have been some 13's with the prob.
01-01-2013 12:46 PM
Numbercruncher
Quote:
Originally Posted by Txrdstr View Post
Has a check engine light ever came on? Sounds like symptoms of a bad drivers side head the 12's and some early 13's are having. Can search " head" and get lots of info. But symptoms are unusually loud ticking on driver side and low fuel mileage with loss of power.
I have followed the bad head as closely as I can and I thought the holy grail was the julian build week. If you see the build number and it is greater than 2062 you were safe. 206 is the week built and the final two is for model year 2012. Based on this and not hearing about needing a build number that has a 3 for model year 2013 I had hoped all the 2013's were fine. Am I wrong in this assumption?

NC
01-01-2013 08:34 AM
Con Artist
Quote:
Originally Posted by Holly84 View Post
Just wanted to say thank you for all your comments as to what could be wrong with my jeep.. With all the crappy service I have gotten and with them still not having a clue what there doing (had it in the shop for a coolant leak.. It came out with coolant cap still open, no engine cover, and a clunk on the drivers side ) we have decided to trade it in.. It was a nice vehicle but not worth all the stupidity.. Hopefully in the future we can purchase another one
Did you already trade it in? If not, find another dealership who may be a little more willing to help you out. I'd also fire back with all these "mishaps" they've caused, especially with Chrysler's customer service department.
01-01-2013 03:00 AM
Holly84 Just wanted to say thank you for all your comments as to what could be wrong with my jeep.. With all the crappy service I have gotten and with them still not having a clue what there doing (had it in the shop for a coolant leak.. It came out with coolant cap still open, no engine cover, and a clunk on the drivers side ) we have decided to trade it in.. It was a nice vehicle but not worth all the stupidity.. Hopefully in the future we can purchase another one
12-30-2012 03:42 PM
amarillojeepguy ive kinda had same problems....can hear a grinding noise and have a tick...maybe im a perfectionist but my fuel had been around 18 to 19 on the highway and now im getting 15 - 16. again stealership says nothing wrong and chrysler will not listen to me on the deal. mine sometimes is sluggish but not anymore than what i might expect but definitely have tick...already been in shop for heater core and leaks and cruise control which they still cant figure out and shooting in the dark by replacing the control buttons. becoming very dissapointed to the point i just wanna trade it off mainly due to lack of service or help in resolving what i feel are isssues with jeep
12-30-2012 03:18 PM
Holly84 Trust me I won't... I've been dealing with them for a squeal no one could figure out until it started to leak coolant now they figured out the water pump is shot... But that's on back order go figure...
12-30-2012 03:07 PM
j0nx Bad head most likely. Don't take the dealer runaround BS.
12-30-2012 03:02 PM
Txrdstr
Quote:
Originally Posted by Holly84
The light did come on .. But because there computers didn't say anything there was nothing they could do... And she lags as well... Ill ask them to check it out and see if that's what my issue is.. Thanks a bunch
YW, and good luck.
12-30-2012 02:59 PM
Holly84 The light did come on .. But because there computers didn't say anything there was nothing they could do... And she lags as well... Ill ask them to check it out and see if that's what my issue is.. Thanks a bunch
12-30-2012 02:56 PM
Txrdstr
Quote:
Originally Posted by Holly84
Yes they say its a plug an that its normal .... Don't sound normal to me
Has a check engine light ever came on? Sounds like symptoms of a bad drivers side head the 12's and some early 13's are having. Can search " head" and get lots of info. But symptoms are unusually loud ticking on driver side and low fuel mileage with loss of power.
12-30-2012 02:50 PM
Holly84 Yes they say its a plug an that its normal .... Don't sound normal to me
12-30-2012 02:49 PM
Txrdstr
Quote:
Originally Posted by Holly84
Hi there, I'm new to this sort of thing.. I bought a new 2012 sahara unlimited fully loaded, I was getting 500km to a tank of fuel and now I'm only getting between 205-248km to a tank of fuel.. Has anyone else had this issue or know what might cause this. I have had it to 2 dealerships and neither one can figure it out
Do you hear any unusual ticking from the motor?
12-30-2012 02:43 PM
PA . JAY theirs couple times where i think i just got a bad tank of gas where i wouldnt get more the 13 -14mpg then text time i fill up i get 17mpg.
12-30-2012 02:37 PM
Holly84 I bought it dec 2011 and had no issues with the fuel then during the winter and it was the first fully loaded vehicle I had lol so I used the remote start more then I do now .. Ud think it would get better on fuel and not worse..
12-30-2012 02:27 PM
SilverSport I can think of several potential reasons: cold weather increases fuel consumption, winter blend gas reduces gas mileage, using 4WD, and extended idling to let your Jeep warm up.
12-30-2012 02:22 PM
Holly84
2012 poor fuel mileage

Hi there, I'm new to this sort of thing.. I bought a new 2012 sahara unlimited fully loaded, I was getting 500km to a tank of fuel and now I'm only getting between 205-248km to a tank of fuel.. Has anyone else had this issue or know what might cause this. I have had it to 2 dealerships and neither one can figure it out

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:20 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC