Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Anyone know voltage for the signal wire of the TPS when ignition is on?

Join Wrangler Forum Today


Thread: Anyone know voltage for the signal wire of the TPS when ignition is on? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-01-2013 02:59 PM
pwbum1 Thanks for the answers, it turned out to be a bad TSP, I measured the orange and striped wire idle and full throttle connected. Highest was 1.47v instead of the 4.6. Had the old one laying around and plugged it in now it works perfectt no grumble and no check engine light for now.
01-01-2013 01:31 PM
Jerry Bransford 5v is the usual sensor voltage which is provided by the PCM.

Orange goes to a source of steady 5v at the PCM.
Orange/dark blue is the center "wiper" connector & it provide the variable TPS output voltage to the PCM.
Black/light blue is the "negative" side but it passes through the battery temperature sensor first before it connects to the PCM.

The below is from the factory service manual...

OPERATION
The TPS is a 3–wire variable resistor that provides
the Powertrain Control Module (PCM) with an input
signal (voltage) that represents the throttle blade
position of the throttle body. The sensor is connected
to the throttle blade shaft. As the position of the
throttle blade changes, the resistance (output voltage)
of the TPS changes.
The PCM supplies approximately 5 volts to the
TPS. The TPS output voltage (input signal to the
PCM) represents the throttle blade position. The
PCM receives an input signal voltage from the TPS.
This will vary in an approximate range of from .26
volts at minimum throttle opening (idle), to 4.49 volts
at wide open throttle. Along with inputs from other
sensors, the PCM uses the TPS input to determine
current engine operating conditions. In response to
engine operating conditions, the PCM will adjust fuel
injector pulse width and ignition timing.
The PCM needs to identify the actions and position
of the throttle blade at all times. This information is
needed to assist in performing the following calculations:
˛ Ignition timing advance
˛ Fuel injection pulse-width
˛ Idle (learned value or minimum TPS)
˛ Off-idle (0.06 volt)
˛ Wide Open Throttle (WOT) open loop (2.608
volts above learned idle voltage)
˛ Deceleration fuel lean out
˛ Fuel cutoff during cranking at WOT (2.608 volts
above learned idle voltage)
˛ A/C WOT cutoff (certain automatic transmissions
only)
01-01-2013 01:26 PM
s14sh3r From the FSM for my 97:

Quote:
The TPS can be tested with a digital voltmeter.
The center terminal of the TPS is the output terminal.
With the ignition key in the ON position, check the
TPS output voltage at the center terminal wire of the
connector. Check this at idle (throttle plate closed)
and at Wide Open Throttle (WOT). At idle, TPS output
voltage should must be greater than 200 millivolts.
At wide open throttle, TPS output voltage must
be less than 4.8 volts. The output voltage should
increase gradually as the throttle plate is slowly
opened from idle to WOT.
01-01-2013 01:19 PM
pwbum1
Anyone know voltage for the signal wire of the TPS when ignition is on?

I am having the TPS code thrown at me and rough engine when I hit the peak of driving at a steady speed. i ahev taken the throttle body off and tested the TPS itself.35volts at idle and 5.2 volts and max. I am pretty sure that si within paratmeters but cant find exacts. I have a Haynes and a FSM iwht no notes in either for exact specs. Also when i tesed the wires with disconnected from the TPS and ignition on (key turned fwd) I have three cables runnign to the TPS connection, a bright orange, bright orange and black striped in the middle and then a brown and yellow striped. from what I can gather the brown and yellow is ground, orange is power 5 volts, adn oraneg and black is the signal wire with a 4.6 volt on the meter. There is my other question, should the signal wire from the TPS be reading 4.6v with the igintion on and no TPS connected? Is it somehow gettign juice/power from somewhere else by accident? Any help would be greatly appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:33 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC