Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Low battery voltage help...

Join Wrangler Forum Today


Thread: Low battery voltage help... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-02-2013 07:49 PM
ninjaturtle0 I will do the disconnect of the battery I hope it's not something expensive to fix
01-02-2013 07:04 PM
JEEP02748 Easiest way to check the alternator is to start the vehicle and while running disconnect the battery. if it keeps running the alternator is still good.
01-02-2013 07:03 PM
jkp Most parts stores will check your alternator for free.
01-02-2013 07:00 PM
ninjaturtle0 How can I check alternator? When they did the test they said its not charging
01-02-2013 06:56 PM
VSantoro The Voltage Regulator is in the PCM (ECM). I ran into the same issue a few months ago. I had other issues after the local auto parts store gave me an computer for an Automatic instead of a Manual. Not a cheap fix. I would make 100% certain the Alternator isn't bad.
01-02-2013 06:52 PM
jkp Probably the alternator. Have it tested.
01-02-2013 06:50 PM
ninjaturtle0
Low battery voltage help...

A few days ago I got the Check Gadges light bc my battery was running at 1/4.

Today on my way home my battery slowly went down to the red so I went to auto shop and yes my battery was bad and I couldn't start my Jeep. I replaced the battery and the voltage meter is still at 1/4 with the CG light on!

Any suggestions?? The guy at auto shop said it could be my alternator but the alt is only 2 years old

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC