Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > BL & MML last minute tips.

Join Wrangler Forum Today


Thread: BL & MML last minute tips. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-12-2013 02:23 PM
MosesTJ Brown dog full MML
01-12-2013 02:12 PM
Binner
Quote:
Originally Posted by MosesTJ View Post
Of finished product?
Yes.
01-12-2013 02:07 PM
MosesTJ
Quote:
Originally Posted by Binner
Pics?
Of finished product?
01-12-2013 02:05 PM
Binner Pics?
01-12-2013 02:02 PM
MosesTJ Drivers side took me 2hrs and passenger side took me 20mins...go figure
01-12-2013 02:00 PM
CarolinaBound I would think it would be. One less piece to line up. After it was all set down though everything wound up nice and snug. If I had to do it over again I would rent or borrow and air gun and get some metal rod to line up the mounts before lowering it so it would be lined up.
01-12-2013 01:38 PM
MosesTJ Glad to hear it. I thought I had problems with it until I heard yours. I did go with the full mount which I thought would be easier.
01-12-2013 01:36 PM
CarolinaBound Yep it was a bitch but its all finished up. A second time through knowing what I need to do definitely would be a breeze. I'll try to get some pics
01-12-2013 01:21 PM
MosesTJ Carolina did you ever get done?
01-10-2013 06:09 PM
CarolinaBound Nope, Big ol' block of steel. The bastard is teasing me, bites harder and breaks loose
01-10-2013 06:03 PM
MosesTJ I ended up using the original bolt instead of the one provided, I had the full mount though not the spacers. I thought you had the full replacement mount is whole time.
01-10-2013 05:57 PM
CarolinaBound
Quote:
Originally Posted by MosesTJ View Post
Which bolt? To the body or the one through the mount itself?
My bad didn't specify. On top, goes through the mount and spacer and the bracket on the frame. Not the cross member.
01-10-2013 05:55 PM
MosesTJ
Quote:
Originally Posted by CarolinaBound
Spent 2 hours on the last bolt. Literally last one and I'm done. The hole lines up perfectly, and the bolt begins to go in, but after it tightens up it just breaks loose again and spins. At a completely loss. We tried loosening everything else up and retightening, lifting it up and setting it back, but the bolt refuses to go in past a point. At a loss.
Which bolt? To the body or the one through the mount itself?
01-10-2013 04:16 PM
CarolinaBound Spent 2 hours on the last bolt. Literally last one and I'm done. The hole lines up perfectly, and the bolt begins to go in, but after it tightens up it just breaks loose again and spins. At a completely loss. We tried loosening everything else up and retightening, lifting it up and setting it back, but the bolt refuses to go in past a point. At a loss.
01-09-2013 09:59 PM
CarolinaBound I'm done for the night. After showering and going out to dinner don't feel like being greasy again. Begin at 10 tomorrow. Here a pic
01-09-2013 07:15 PM
MosesTJ
Quote:
Originally Posted by BLK00TJ
It's really not that bad. You just have to have patience, especially with the MML. I cursed a lot for that one, but felt dumb when I was finished because of stupid mistakes.

My stumbling block was that I couldn't keep the mount and the spacer together during the install. I immediately thought to myself that I should go in the house and tape them together with painters tape. 2 hours later from my own stubbornness I finally got it in withhout the spacer sliding off. That's 2 hours of my life I'll never get back.

The body lift took me about 2 hours and most of that was messing with the fan shroud since I did it separate from the MML. I snapped 2 of the four bolts and ended up ziptie-ing where the bolts were missing. It's still like that 3 years later.
I did the full mount replacement instead of the spacer. I'm not sure which is harder.
01-09-2013 07:12 PM
BLK00TJ
Quote:
Originally Posted by BigDeaner View Post
Its stories like these that make me want to avoid doing a BL and MML... Good luck to the OP and for what its worth, pictures go a LONG way in giving the experts on these boards (no me) a better sense of whats going on.
It's really not that bad. You just have to have patience, especially with the MML. I cursed a lot for that one, but felt dumb when I was finished because of stupid mistakes.

My stumbling block was that I couldn't keep the mount and the spacer together during the install. I immediately thought to myself that I should go in the house and tape them together with painters tape. 2 hours later from my own stubbornness I finally got it in withhout the spacer sliding off. That's 2 hours of my life I'll never get back.

The body lift took me about 2 hours and most of that was messing with the fan shroud since I did it separate from the MML. I snapped 2 of the four bolts and ended up ziptie-ing where the bolts were missing. It's still like that 3 years later.
01-09-2013 07:08 PM
MosesTJ
Quote:
Originally Posted by BigDeaner
Its stories like these that make me want to avoid doing a BL and MML... Good luck to the OP and for what its worth, pictures go a LONG way in giving the experts on these boards (no me) a better sense of whats going on.
It's much like doing any mod on any vehicle. It never goes as planned.
01-09-2013 06:55 PM
BigDeaner Its stories like these that make me want to avoid doing a BL and MML... Good luck to the OP and for what its worth, pictures go a LONG way in giving the experts on these boards (no me) a better sense of whats going on.
01-09-2013 06:39 PM
MosesTJ
Quote:
Originally Posted by CarolinaBound
About to kill someone over the motor mount. All the bolts are out on it except for the cross member. A BFH and crowbar got it out to the point none is showing on the side the nut used to be (passenger side). Pounding on it doesn'tseem to make it budge, and neither does spinning it even though it does turn. Help me?
I had this problem on the drivers side and I lowered the motor to get it to come out, I just had it jacked up to far.
01-09-2013 05:55 PM
CarolinaBound About to kill someone over the motor mount. All the bolts are out on it except for the cross member. A BFH and crowbar got it out to the point none is showing on the side the nut used to be (passenger side). Pounding on it doesn'tseem to make it budge, and neither does spinning it even though it does turn. Help me?
01-08-2013 08:42 PM
MosesTJ I did the same setup this weekend except I had to remove a 3" body lift. Drivers side MM was hard for me but passenger side was a breeze. I used a 4x lubricant on the mount to help slide it in. It was easiest for me to set the mount on the body and start the nut on the bottom, then get the mount in the cradle before the top bolt.
01-08-2013 08:09 PM
krisbman
Quote:
Originally Posted by CarolinaBound
Disregard the above, BL is all set. BFH slid the puck over a tad, enough for the bolt to bite.

Now the MML has me ready to burn down the garage, mostly because I have every size socket except 18mm.
Little tip that works sometimes. Put sum duct tape over the bolt and use a standard size socket. Not sure which one is close.
01-08-2013 08:03 PM
CarolinaBound Disregard the above, BL is all set. BFH slid the puck over a tad, enough for the bolt to bite.

Now the MML has me ready to burn down the garage, mostly because I have every size socket except 18mm.
01-08-2013 07:37 PM
ljjp10 Do you have the transfer case linkage disconnected? something is binding . I just added a 1" lift and had to extend
01-08-2013 07:22 PM
krisbman
Quote:
Originally Posted by CarolinaBound
Where could I pry from to get the leverage? The bar I have is ~2 feet, which is barely longer than the distance from the frame to the tub.
Put the bar through the hole
01-08-2013 06:47 PM
ljjp10 Remember some of your bolts are longer than others.
01-08-2013 06:40 PM
CarolinaBound Where could I pry from to get the leverage? The bar I have is ~2 feet, which is barely longer than the distance from the frame to the tub.
01-08-2013 04:14 PM
krisbman I would loosen everything back up and use the pointed end of a pry bar to persuade it. Start with the difficult one first
01-08-2013 03:22 PM
CarolinaBound Last bug before I pester everyone about the MML. Front driver side body mount refuses to line up. The tub is about 1/8 inch off from the spacer/bracket on the frame. I tightened up all the ones on the passenger side hoping it would tug it over, did a bit but not too much. Going to tighten up the front mount to see if that gives me any more room, if not I'm out of ideas. All other driver side mounts are just spun in by hand still
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC