Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Right turn signal won't turn on.

Join Wrangler Forum Today


Thread: Right turn signal won't turn on. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-15-2013 03:45 PM
sevenservices Good find... good thinking on isolating the issue as well.
01-15-2013 01:39 PM
TwoPointFiveLiter Yup, it was a bad ground. It just really threw me off that it happened to start being a problem exactly when I put the new steering column in.

But yeah, I found the two grounds near the headlights, took em off and cleaned em up and everything worked perfectly after.
01-14-2013 08:12 PM
TwoPointFiveLiter gotta be a bad ground.

Now that it's night, I noticed one of the parking lights in front is dim, and the right turn signal started illuminating on the dash. Then stopped. Then started again.

Didnt fix the problem when it was on, however. :/ which also points to a ground issue.
01-14-2013 03:24 PM
TwoPointFiveLiter
Quote:
Originally Posted by ThePhantomPatriot View Post
If it flashes at a weird and inconsistent timing it could be the relay located on the fuse box under your driver side dash. There's one for hazards and one for blinkers. I had to replace mine because sometimes my blinker would just light up and not blink other times it would blink, stop, blink, etc.
nah, it's just plain not coming on.
01-14-2013 03:07 PM
ThePhantomPatriot If it flashes at a weird and inconsistent timing it could be the relay located on the fuse box under your driver side dash. There's one for hazards and one for blinkers. I had to replace mine because sometimes my blinker would just light up and not blink other times it would blink, stop, blink, etc.
01-14-2013 01:40 PM
TwoPointFiveLiter Okay, so I swapped out the hazard and turn signal flashers and nothing changed, so it's not that...hmm...

Gah...Im gettin ticked off.
01-14-2013 01:07 PM
TwoPointFiveLiter tried it. It's not the bulbs cause the left side still worked with the right side bulb in it, and the ride side didnt work with the bulb I knew was workin.

Is there any chance it's the turn signal switch?
01-14-2013 12:54 PM
TwoPointFiveLiter
Quote:
Originally Posted by TwoPointFiveLiter View Post
Haha, I hope not! I've put so much money into fixing this Jeep by now that I coulda bought a real nice one for the same price!

Anyways, Yeah, I'll try that, but the dash bulb I know is not defective because I pulled the bulb out of the left signal slot that was working, threw it in the right signal slot and it didnt work. then I threw it back into the left slot and it worked again.

And before I swapped the steering wheel, everything worked fine, which makes me think that something is bad in there. or during the swap I caused a bad ground. I havent looked under the dash too much since I bought it, but it looks like a mess under there.
just as a quick look, I'll swap the right and left front signal bulbs and see what happens.
01-14-2013 12:45 PM
TwoPointFiveLiter
Quote:
Originally Posted by sevenservices View Post
doh, thats the end of it. you'll have to sell the jeep now.

lol

check your right front bulb first. They are cheap and will cause that sometimes... Aside from that, trace the wire back from the dash light and see if its disconnected or cut somewhere. the front and back should run off the same blinker so it makes me think either the bulb up front is bad or the bulb in the dash is bad or disco'd.
Haha, I hope not! I've put so much money into fixing this Jeep by now that I coulda bought a real nice one for the same price!

Anyways, Yeah, I'll try that, but the dash bulb I know is not defective because I pulled the bulb out of the left signal slot that was working, threw it in the right signal slot and it didnt work. then I threw it back into the left slot and it worked again.

And before I swapped the steering wheel, everything worked fine, which makes me think that something is bad in there. or during the swap I caused a bad ground. I havent looked under the dash too much since I bought it, but it looks like a mess under there.
01-14-2013 12:41 PM
sevenservices doh, thats the end of it. you'll have to sell the jeep now.

lol

check your right front bulb first. They are cheap and will cause that sometimes... Aside from that, trace the wire back from the dash light and see if its disconnected or cut somewhere. the front and back should run off the same blinker so it makes me think either the bulb up front is bad or the bulb in the dash is bad or disco'd.
01-14-2013 12:29 PM
TwoPointFiveLiter went out and checked it again, and the rear signal is actually working. I coulda sworn it wasnt, but it is.

So I guess the only signal not working is the front passenger side and on the dash. all the others work (except the front fender blinkers.)

Both when I use the hazards, and when my turn signal is on, the right side will not flash. but the bulbs will light up when I have my lights on, so it's not a bulb issue, they just don't flash...:/
01-14-2013 12:17 PM
TwoPointFiveLiter also, I have brake lights, and when my lights are on, they all light up, just don't flash.
01-14-2013 11:57 AM
TwoPointFiveLiter
Right turn signal won't turn on.

Just put a new steering column in when I accidentally snapped my turn signal lever...

Anyways, the swap went smooth, but now my right turn signal doesnt work! The left one works fine, but the right one will click into position and nothing happens.
No light on the dash, no blinking in the front or the back. When my hazards are on, only the left one comes on.

It also appears that the side lights on the front, on the fenders also won't blink. That doesn't bother me as much though.

Would that be the turn signal switch? if so, I have a spare but don't wanna take the whole steering column apart when it's right at the top. Could I just snip the wires and snip the wires on the spare and solder them together?

It's a 1989, 2.5L, 5 speed, without tilt or intermittent wipers. Thanks guys!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC