Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > HELlP PLEASE!!! Radiator Problems!

Join Wrangler Forum Today


Thread: HELlP PLEASE!!! Radiator Problems! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-21-2013 10:05 AM
obidya
Quote:
Originally Posted by robx4 View Post
I just installed one of the CFS all brass radiators on my TJ in September. Rock solid and went in just like OE. Best part is lower temps across the board. Highly recommended!
thats exactly what I am planning on, that and an electric fan.
01-21-2013 10:03 AM
robx4 I just installed one of the CFS all brass radiators on my TJ in September. Rock solid and went in just like OE. Best part is lower temps across the board. Highly recommended!
01-21-2013 09:59 AM
obidya When mine finally goes im going to get an old school brass monster. It will outlast the aluminum and out cool the aluminum. The only problem is they are heavy, but I'm already compensating for a winch and other up front the extra few lbs is no concern of mine.
01-21-2013 08:54 AM
ohioviper Just replaced an autozone radiator in my sons TJ . We put it in day before Thanksgiving and had a small leak ever since I could not find.Was starting to think head or head gasket.
It was split at the very bottom and I swear you could not see it leaking but you could feel it was damp. It finally let go yesterday and pissed out. They swapped no questions asked .

The OEM one is also plastic top and bottom. I am leaning towards an all aluminum one or an exact oem one. Where are folks getting the OEM one and what brand is it ? The one from Autozone is a Spectre which I read was the OE supplier ?
01-21-2013 07:13 AM
dwesto I just got done replacing the lifters on my 03 Rubicon about 2 weeks ago and when i replaced the thermostat gasket it was leaking from the bottom of the thermostat housing. I took it apart again and found the gasket would tear cause it was too thin and didn't fit properly. I bought some thicker gasket material and made the gasket. It was really easy and fixed the leak
01-21-2013 07:02 AM
Wattapunk I would also check the upper hose and thermostat housing. Any upper leaks could run down the motor and give the appearance of a bottom leak. It will also cause the smoke from the leak boil off on the engine. How did you burp the radiator and did the new thermostat came with a vent hole?
01-20-2013 09:03 PM
Aust9002 I think we might just have a hole in the hose we put on there. But the unfortunate thing is that they were brand new...
01-20-2013 07:40 PM
clarkkent I would fill it with water and then use a pressure tester to see where it is leaking.

After two aftermarket all aluminum radiators failing me I finally just bought an OEM replacement online.
01-20-2013 07:19 PM
doclouie We need pictures to really help.
01-20-2013 06:34 PM
BadPenny Could be leaking from the water pump?
01-20-2013 06:33 PM
JPi4.0 Is leaking in front of the engine and running down the pan?
If it is its your water pump. It has a weep hole in the pump. When the seal goes out the water leaks out of the weep hole
01-20-2013 06:29 PM
Aust9002
Wasn't a cheap radiator

We bought a good radiator from napa and it is deffinetly not leaking from the actual radiator.
01-20-2013 06:15 PM
doclouie It is coming from somewhere. Pour it in and see. If you put a cheapo radiator in I have heard about them coming straight from the factory with leaks. The PO put in a radiator into mine from Autozone and it only lasted 1.5 years.
01-20-2013 06:05 PM
Aust9002
HELlP PLEASE!!! Radiator Problems!

The other day we replaced my radiator in my '97 TJ and the hoses a couple days later it was starting to leak or at least we thought so today we replaced the factory clamp with a better one and made sure the bottom hose was on there tight. Then we filled it back up with fluid and burped it after we burped it I took it for a drive around the block and the temp got over 260 degrees and started to smoke everywhere when we looked to see if the hose was still connected it was on there perfectly and it leaked almost all of the radiator fluid out and it almost looked like it was leaking from the oil pan Please Help!!! any ideas? when we replaced the radiator we also replaced the thermostat and all of the hoses.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC