Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Colorado Jeep Forum > Battery issue?

Join Wrangler Forum Today


Thread: Battery issue? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-30-2013 06:36 PM
BrianTG
Quote:
Originally Posted by Tshields
May just be the picture, but the negative terminal does not look very tight on the post. Grab both of your battery connections and try to twist them, if you can move they are not tight.
Just did that and no movement at all.

Also started it up just fine. Let it sit for a few mins with no issue. Turned it off then back on five mins later with no issue.

So it seems to be related to whatever caused the battery gauge to spike while I'm driving.
01-30-2013 06:25 PM
03 sahara jeeper Sorry didn't read the above post.
01-30-2013 06:23 PM
03 sahara jeeper Some people poor coke on the terminals, I use baking soda and water.
01-30-2013 06:07 PM
Tshields May just be the picture, but the negative terminal does not look very tight on the post. Grab both of your battery connections and try to twist them, if you can move they are not tight.
01-30-2013 04:21 PM
BrianTG Lol. Just what I need on a day I work a double.
01-30-2013 03:55 PM
BeauJeep As I posted noticed you updated with pictures. That's some good corrosion going on there.

To clean a terminal isn't that hard. They sell battery terminal brushes that will do it and some sprays that will break it down and clean, but if you don't want to spend money you can use a toothbrush, baking soda and water.

A good instruction set I've followed:
  • Remove the ground connection first by removing the negative (-) terminal from the post (note: older vehicles may have a positive ground)
  • Remove the positive (+) terminal from the post
  • Scrub any corrosion off the terminals, cables and posts using a stiff brush
  • For tough buildup, use a solution of baking soda and water, taking special care that none gets inside the battery
  • Dry it off with clean cloth
  • Reconnect the terminals in the reverse order from which you removed them, positive (+) first, then negative (-)
  • Double-check to make sure the connections are tight and secure
01-30-2013 03:47 PM
BeauJeep Could be quite a few different things. I'd check the terminal points and make sure they are tight and not corroded. Have AutoZone or someone test your battery and alternator (free), voltage regulator, and with your battery needle fluctuating between under power and idle at the stop light I'd almost be willing to check your belt.
01-30-2013 03:45 PM
BrianTG So went out and checked it again. Still dead. Hit lights and blinkers all worked then I could start it no issue.



Attachment 203704



Attachment 203706

And sadly I have no idea how to clean them if they are indeed the issue.
01-30-2013 01:34 PM
03 sahara jeeper You might want to get the alternator checked. Also check that all of your terminals are clean and tight.
01-30-2013 12:46 PM
BrianTG
Battery issue?

So drove the jeep about two miles to the dog park. No issues, drove home, no issues. Leaving for work and it dies. And I mean dead. Put the key in and turn it all the way and nothing. No gauges at all. Head lights work. Waited about 5 mins and it starts no issue at all. Driving to work I notice the battery gauge is all the way maxed. I hit a red light and it drops to normal. Drive the rest of the way and its fine till I down shift to 3rd and it spikes again. Park it and turn it off and it's dead again. Ideas??

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC