Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > I upgraded 130 to 430 RBZ and I'm not looking back.

Join Wrangler Forum Today


Thread: I upgraded 130 to 430 RBZ and I'm not looking back. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Yesterday 01:04 PM
Rammer500
Quote:
Originally Posted by Jkuone View Post
Now that is a sobering statement...Ha.!
And a Shame that this is how the world is now.
Yesterday 12:49 PM
Jkuone
Quote:
Originally Posted by any4xx View Post
Well I hope you guys are right. I've REALLY been wanting to ditch my 130 and was leaning hard toward Kenwood. But I have to come to grips with the fact that the town I live in is a shithole and any aftermarket stereo will likely just be stolen within six months. So I ordered my RBZ this morning. Merry Christmas to me...
Now that is a sobering statement...Ha.!
Yesterday 12:41 PM
any4xx Well I hope you guys are right. I've REALLY been wanting to ditch my 130 and was leaning hard toward Kenwood. But I have to come to grips with the fact that the town I live in is a shithole and any aftermarket stereo will likely just be stolen within six months. So I ordered my RBZ this morning. Merry Christmas to me...
Yesterday 08:24 AM
Rammer500 If I remember right, Menu key, system setup, system info or something like that. Let me know what version it has and I'll walk you through the update process.
Yesterday 08:21 AM
ToonGuy Thank you, I will look into it.
Yesterday 08:17 AM
Rammer500 If you have the blue screen, there is an update for it.
Yesterday 08:08 AM
ToonGuy Like a charm! 15 mins. and we were rockin out. It's a blue back light, and like the others it doesn't bother me against the mostly blue screen. It powered up Dodge and after entering the code switched to Jeep. I've got a lot to learn, I'm not very well versed in these new gadgets LOL. Within 2 mins my son had his Pandora playing through it...
Yesterday 08:04 AM
Rammer500
Quote:
Originally Posted by ToonGuy View Post
Awesome thanks Rammer500! I had my son snap a pic of the unit, sent them the info and they sent me the code in about 20 min! Swapping it out tonight, can't wait!
NICE! Lets us know how it worked out and the back lighting color for reference.
Also check the software version it has, there might be an update for it. The newest version has a black/gold theme instead of the ugly blue/white.
12-23-2014 02:40 PM
ToonGuy Awesome thanks Rammer500! I had my son snap a pic of the unit, sent them the info and they sent me the code in about 20 min! Swapping it out tonight, can't wait!
12-23-2014 08:46 AM
Rammer500
Quote:
Originally Posted by ToonGuy View Post
Thank you, that is positive news. I have a few hours tonight, I may install it and try to crack the code. My '12 came with Connectivity / Uconnect and I'm not adding anything additional...just swapping to get the touch screen so if I understand correctly I don't need to have my unit "flashed" at the dealer...correct?
That is correct. You just need the security code. You can get that here, if you don't want to go through the dealer:CHRYSLER® DODGE® JEEP® UCONNECT® MYGIG® SECURITY CODE RETRIEVAL – NavRepair.com
12-23-2014 08:16 AM
ToonGuy Thank you, that is positive news. I have a few hours tonight, I may install it and try to crack the code. My '12 came with Connectivity / Uconnect and I'm not adding anything additional...just swapping to get the touch screen so if I understand correctly I don't need to have my unit "flashed" at the dealer...correct?
12-22-2014 06:46 PM
Rammer500 Usually, the letters show revisions and/or differences in colors. They start at AA then AB etc. It could have different color backlighting, newer firmware installed then the AB. That part # should still work for you.
12-22-2014 04:33 PM
ToonGuy Please forgive me if this has been covered, I've read so many pages they all ran together! Question: Do the last letters mean anything in relation to high speed or low speed? I purchased a 2012 unit that was listed as being from a Grand Caravan for my '12 Unlimited from LKQ off of Ebay. In the listing the part number was listed ending in AB. When the unit showed up today the part is actually P05091201AC. A quick google shows it should be a high speed unit, but can anyone confirm?

If I have to swap it out with the seller it won't be the end of the world, as the dealer is 3 weeks out on getting it in for the theft code (and some other work) but hopefully I won't have to.
12-11-2014 06:49 PM
gatzby143 I just bought one out of '11 Dodge Nitro. Anyone have any idea what color the backlight on the buttons will be?
12-10-2014 09:53 PM
Travrsx Just installed my RBZ from a 2012 RAM. I bought it on eBay from a guy who had the radio pulled from his showroom new truck, and a nav unit installed. The 430 is a 05091170AC model and he provided the security code. It's a mid 2011 build with green backlighting.

It still had the old version 33.00.41 software, so the first thing I did was update to 50.00.07. Much better, I love the black theme.

This radio is a huge improvement, not only aesthetics but sound quality. I have read that some people don't notice a difference, but I did. Also, it drives my (mopar kicker "KICK10") speakers much louder. Cruising in the highway used to require my volume to be set at or above 75%... Now the same volume is achieved closer to 50%. Really surprising.

Also, I love being able to see what songs are playing on all my sirius presets without tuning to that station.

I'm really happy! Thanks to everyone who posted info in this thread.
12-07-2014 09:18 PM
Gumbys69 Remember to check your local Autowrecker, I got mine from there for $200 Canadian, so probably cheaper in the US. I have a scan tool that can see how long it has actually been used and how many discs have been played in it. I lucked out and got one that had played 3 discs and been used just over 10 hours so it was pretty much brand new AND it had the green backlit buttons and changed to the Jeep logo right away. Check the wreckers guys!!!!
12-07-2014 08:26 PM
Killingtonvt I just purchased and installed a 430 RBZ that I found on Ebay. The seller is mygigsales and is selling newer Sirius/Antitheft units for $369. They were able to confirm green back lights for me! The model number I received is p05091327ae.

Hope that helps!
12-07-2014 01:48 AM
bassani the ones i have been seeing on eBay have been the "RB2" versions which supposedly dont support Sirius b/c they were pulled from vehicles going to foreign countries.

Is that the case?

What is the exact model number of the most current US version of the 430 unconnect w/o nav?
12-06-2014 12:13 PM
Tnewcomb Just installed one I got from Ebay for $250. Excellent upgrade from the stock radio and only took 15 minutes to install.
11-29-2014 01:17 PM
DallasJKU
Quote:
Originally Posted by Rammer500 View Post
No, It's plug and play.

If you want to add a backup camera and/or the uconnect hands free blue tooth module, that's when it will need to be flashed. If you want to add both, have both sales codes flashed at the same time. My dealer charged 1/2 hour labor to do them. Having them done separate would cost you twice.
UConnect is a must and the backup camera option was why I wanted the 430.
11-29-2014 06:05 AM
Rammer500
Quote:
Originally Posted by DallasJKU View Post
The eBay pics show the serial and part number so I guess I could get the unlock code first. Does it still need to be flashed at dealer??
No, It's plug and play.

If you want to add a backup camera and/or the uconnect hands free blue tooth module, that's when it will need to be flashed. If you want to add both, have both sales codes flashed at the same time. My dealer charged 1/2 hour labor to do them. Having them done separate would cost you twice.
11-29-2014 12:02 AM
DallasJKU
Quote:
Originally Posted by Rammer500 View Post
Looks like they just need the part number and serial number of the one you need the code for. Post up a picture of what your working with, maybe someone can help ya.
The eBay pics show the serial and part number so I guess I could get the unlock code first. Does it still need to be flashed at dealer??
11-28-2014 10:12 PM
Rammer500
Quote:
Originally Posted by DallasJKU View Post
Do they need a VIN #??
Looks like they just need the part number and serial number of the one you need the code for.

Post up a picture of what your working with, maybe someone can help ya.
11-28-2014 08:40 PM
DallasJKU I went ahead and took dash apart. Pretty easy. I wanted to see if I could somehow pull the radio back into place. The radio was shoved back when I had a full-size portable soccer goal pushing against it. The mounting bracket won't pull back into place. The bottom of my radio is still shoved 1/4-3/8" back and I can't seem to pull it back into place without snapping everything. Any ideas??
11-28-2014 07:02 PM
DallasJKU
Quote:
Originally Posted by Rammer500 View Post
I couldn't tell you, Mine doesn't have the anti-theft feature and didn't need a code. They are a legit business, so I wouldn't have a problem using them for a code if I needed one.
Do they need a VIN #??
11-28-2014 04:24 PM
Rammer500 I couldn't tell you, Mine doesn't have the anti-theft feature and didn't need a code. They are a legit business, so I wouldn't have a problem using them for a code if I needed one.
11-28-2014 12:57 PM
DallasJKU
Quote:
Originally Posted by Rammer500 View Post
My dealer said he would at least need the VIN #. Is that site 100% guaranteed to work??
11-28-2014 11:54 AM
DallasJKU So the seller got back to me and said he has sold 7-8 of these units without the codes and everyone of them the buyer took to dealer and they unlocked the 430 for them. Does this sound right??
11-28-2014 08:46 AM
wrix They'll be green. Score!
11-28-2014 04:48 AM
DallasJKU
Quote:
Originally Posted by panthermark View Post
Glad it worked...
Interesting about the dot on the back....but with that said...I think all 509's are in blue. So I wonder what the dot is for?
Would the buttons be blue if it was a 509 from a '13 Rubicon??
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC