Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Fog lights quit working

Join Wrangler Forum Today


Thread: Fog lights quit working Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-15-2013 05:40 PM
mygirlscallhim pedro Thank you to everyone who replied. After buying a volt meter for $25 it was something simple that was wrong. I mount my relay and ground with the same screw on the firewall. screw must have lost contact with wire and since the firewall is painted... No Ground...
02-15-2013 06:45 AM
mygirlscallhim pedro Yes first thing I check were fuses.
02-15-2013 06:40 AM
mygirlscallhim pedro Everything was dry with the exception of the connections at the lights. Should I wrap that connection with elec. tape? I mounted the relay high on the firewall.
02-15-2013 01:18 AM
Brew Maybe a short from the water? How well did you weatherproof the wiring?
02-14-2013 10:22 PM
XwXCHADWICKYXwX I have the KC`s as well
02-14-2013 10:21 PM
XwXCHADWICKYXwX Possibly blew a fuse. Check the fuses on the wire that leads to the lights. Pretty basic but can be forgotten. In my case the entire wire fried but I never use them so I haven't done anything about it yet.
02-14-2013 09:33 PM
mygirlscallhim pedro Jump around relay?
02-14-2013 09:31 PM
Evpjr Jumper around the relay and see.
02-14-2013 09:01 PM
mygirlscallhim pedro
Fog lights quit working

Install new KC fog lights last night everything worked fine. Washed salt off at car wash and lights worked after that. Stopped in town and on way home went to turn them on and nothing. Everything checks out ok? Any thought? Relay go bad?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:48 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC