Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > strange smell while driving.

Join Wrangler Forum Today


Thread: strange smell while driving. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-15-2013 05:17 PM
PStov98TJ If its not brakes it maybe something within the transmission. Good luck. Keep
Us posted here. We might be able to help out.
02-15-2013 05:08 PM
ninjaturtle0
Quote:
Originally Posted by PStov98TJ View Post
You could be dragging a brake pad. Like one is just slightly touching the drum or disk. Enough to heat it up but not enough to slow the jeep down.
taking my Jeep to have the brakes checked this weekend
02-15-2013 03:32 PM
PStov98TJ You could be dragging a brake pad. Like one is just slightly touching the drum or disk. Enough to heat it up but not enough to slow the jeep down.
02-15-2013 03:28 PM
ninjaturtle0
Quote:
Originally Posted by Tjrubicon17 View Post
Happened to me last week. Turned out my the circuitboard behind my gadge cluster shorted out now the lights behind my gadges don't work.
my dash lights still work... I hope something serious doesn't happen!

Jeep runs fine
02-15-2013 02:28 PM
Tjrubicon17 Happened to me last week. Turned out my the circuitboard behind my gadge cluster shorted out now the lights behind my gadges don't work.
02-15-2013 01:42 PM
ninjaturtle0 lmao at Taco Bell

I have Auto transmission, had a flush about 6 months ago so fresh fluid
02-15-2013 01:30 PM
NCJeepin Did you happen to eat Taco Bell beforehand?
02-15-2013 01:26 PM
G.A. Heath If your transmission is a standard it could also be your clutch.
02-15-2013 01:22 PM
ninjaturtle0
strange smell while driving.

it has happen to me twice so far..

I'm stuck in traffic and there is this strong smell and at first I thought it was another car but it happened this morning.

when I had my car before in the past I accidently drove with the emergency brake on and when I noticed it and stopped it had this same smell so I'm thinking it has something to do with my brakes??? but this rarely happens

Thinking of getting my brakes checked this weekend.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC