Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Just My Luck

Join Wrangler Forum Today


Thread: Just My Luck Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-27-2013 11:57 AM
RioGrande95YJ
Quote:
Originally Posted by Charley24

10 days and no answer or pics. Hope he didn't crash!!
Hahahaha
02-27-2013 10:51 AM
Charley24
Quote:
Originally Posted by jokerchief462 View Post
If the entire drive train moved it is time for a little maintenance and inspection before you go out driving again. Why don't you take some pics post em up and lets see the damage and what the probable cause was. This is serious you could have lost control and flippped that thing. We are alll here to help.
10 days and no answer or pics. Hope he didn't crash!!
02-18-2013 08:57 PM
jokerchief462 If the entire drive train moved it is time for a little maintenance and inspection before you go out driving again. Why don't you take some pics post em up and lets see the damage and what the probable cause was. This is serious you could have lost control and flippped that thing. We are alll here to help.
02-18-2013 08:36 PM
Charley24 So, you installed new motor mounts and put everything back together? Might as well try 4H.......
02-18-2013 08:18 PM
PCM
Just My Luck

I'm 17 and my parents bought my first car, a standard 95 red yj with mostly stock parts and a four cylinder engine. Today when I was driving one of those hilly back farm roads, goin around 65 mph, we hit a big bump and when we landed we heard abunch of banging around. After freaking out and alot of panik we called my dad and got it home. Turns out that the engine mounts had broke and everything shifted forward, the drive shaft had moved and was the cause of the banging and the cooling fan was bent and jacked up.
The jeep still drives and the clutch and stick work too. I didnt puncture the radiator. I'm not sure if i want to try and take it out of 2 wheel drive.
If anyone has opinions, info or helpful tips, please don't hold back!
(pictures coming soon)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC