Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 2011 Wrangler JK Bad Mileage Problem

Join Wrangler Forum Today


Thread: 2011 Wrangler JK Bad Mileage Problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-21-2013 09:25 PM
GPA21 Thanks for the responses.

Tires are stock 16s and gear ratio is 3.21 standard.

I realize that for highway driving my mileage is not that bad however in the city it doesn't compare to some other friends of mine who drive Wranglers so i figure something must be a little off.
02-21-2013 08:32 PM
SilverSport
Quote:
Originally Posted by GPA21 View Post
I purchased a 2011 Jeep Wrangler JK new near Toronto in April of 2011 and have had horrific gas mileage since it left the dealership (especially in city driving in Toronto).

My Jeep is a 2011 2 Door Sport w/ Auto transmission and averages 300 km a tank (20.6 L /100 KM or 11.4 mpg) generally filled after 62 litres, and now has about 18,000 kilometres on the ODO. Since even when people say they get bad mileage online they are reporting around 13 mpg I know something must be very wrong. I should note that most of my driving is done in City (90%) and when I am only driving highway I can see up to 480-500 kms/tank.

The shop/dealership (which I purchased from) notes that they can't do much for me after doing a fuel consumption test but says that I should now keep accurate track of my mileage per fill-up for the next 5000 kms and then report the problem to Chrysler.

Has anyone here had a mileage problem this bad and dealt with Chrysler to resolve ? I want to make sure I approach this correctly when I speak with them to ensure that I get them to look at it to figure the problem out.

Thanks all, any help would be appreciated.
You mentioned you can get 480-500 km/tank if driving all highway. If I did the math correctly that works out to 288-300 miles. 62 liters = 16.3 gallons. So somewhere between 17.6 and 18.4 mpg. Not unrealistic there.

You haven't mentioned if the tires are stock, what air pressure you are running, what axle ratio you have, etc. But constant city driving does take a toll on fuel economy. So does winter gas.
02-21-2013 08:23 PM
Syntackz
Quote:
Originally Posted by Spool View Post
I can't understand metric
Metric mileage, pretty straight forward, 21L/100km, means you will burn 21L of fuel for every 100km you drive.
02-21-2013 08:22 PM
Syntackz
Quote:
Originally Posted by GPA21 View Post
Thanks, but regardless I get about 21 L/100 Kms (10.5 MPG) all stock with good driving habits so something must be wrong.
Good driving habits could be subjective :P. Stop and go traffic will eat up a lot of gas. You said you drive in Toronto, I'm assuming lots of stop and go traffic. The accelerating is what does it. I'm sure the mileage gets better while highway driving. I'm willing to bet on the stop and go city driving is the culprit though.
02-21-2013 08:17 PM
Spool I can't understand metric
02-21-2013 08:14 PM
GPA21 Thanks, but regardless I get about 21 L/100 Kms (10.5 MPG) all stock with good driving habits so something must be wrong.
02-21-2013 07:55 PM
Syntackz As far as I know the DTE calculates based on your past driving habits. So it will change and evolve over time depending on how you drive.
02-21-2013 07:39 PM
GPA21 Has anyone else experienced MPG like this ?

I also notice now that when I view my DTE gauge that it goes at pretty much double the speed that it should at all times. I.E. if I drive 5 km it will go down by 10 km.

Any help/advise is appreciated.
02-18-2013 07:24 PM
Syntackz I bought a 2011 from Toronto as well. North York Chrysler actually. I live north of the city. Jeep is stock minus I changed the tires to cooper discover at's. I'm getting around 17.5L/100km.

When I first bought it in October, I was getting around 14L/100km. I've put about 4000km since then, and changed the oil and oil filter.

The tires aren't much larger then what was on there when I bought it. I'm hoping the eco doesn't get much worse without change...
02-18-2013 07:06 PM
GPA21
2011 Wrangler JK Bad Mileage Problem

I purchased a 2011 Jeep Wrangler JK new near Toronto in April of 2011 and have had horrific gas mileage since it left the dealership (especially in city driving in Toronto).

My Jeep is a 2011 2 Door Sport w/ Auto transmission and averages 300 km a tank (20.6 L /100 KM or 11.4 mpg) generally filled after 62 litres, and now has about 18,000 kilometres on the ODO. Since even when people say they get bad mileage online they are reporting around 13 mpg I know something must be very wrong. I should note that most of my driving is done in City (90%) and when I am only driving highway I can see up to 480-500 kms/tank.

The shop/dealership (which I purchased from) notes that they can't do much for me after doing a fuel consumption test but says that I should now keep accurate track of my mileage per fill-up for the next 5000 kms and then report the problem to Chrysler.

Has anyone here had a mileage problem this bad and dealt with Chrysler to resolve ? I want to make sure I approach this correctly when I speak with them to ensure that I get them to look at it to figure the problem out.

Thanks all, any help would be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC