Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Help! Floor lights and radio stopped working!

Join Wrangler Forum Today


Thread: Help! Floor lights and radio stopped working! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-22-2013 01:11 AM
RUBI 4 MY MRS On the 2000 the fuse is #25 in the PDC in front of the battery.
02-21-2013 10:01 PM
2000jk Bump
02-21-2013 08:55 PM
tbensor awesome
02-21-2013 08:26 PM
chrislewis I found it! I pulled all of the fuses under the hood and it was the last one. Sorry about the dumb amateur sounding post. But the wiring of the radio was terrible and I thought it had a lot to do with that. Thanks for the help and motivation to get my ass back out in this blizzard!
02-21-2013 07:59 PM
tbensor hmm. is the harness connected to stock wires
02-21-2013 07:42 PM
chrislewis I am not the original and it looks like a new harness on the radio
02-21-2013 07:38 PM
tbensor this assumes someone didn't hot wire it. Are you the original owner? Can you tell if is using the original harness
02-21-2013 07:36 PM
tbensor Fuse #15 10amp fuse. It should be located in the fuse block behind the glove box. Did you meter it? I would replace it.
02-21-2013 07:32 PM
chrislewis Bump. Sorry I'm desperate and need it fixed asap
02-21-2013 07:15 PM
2000jk Jk bump
02-21-2013 07:13 PM
chrislewis Do you know what fuse to check? I'm fighting an ice/snow storm outside and am running in and out to warm up. lol
02-21-2013 07:11 PM
jeepers29 There are some fuses under the hood as well.
02-21-2013 07:09 PM
2000jk
Quote:
Originally Posted by chrislewis View Post
So I'm hooking up a subwoofer in my TJ. All was going well until we went to push the head unit back in. The top of the head unit made a small spark, then the radio and floor lights stopped working. I have no idea what the hell happened. I checked all of the fuses behind the glovebox and they were all good. I'm officially stumped. Please save me from this silent torture.

(no power to radio, no power to lights, checked the fuses)
I have the same problem
02-21-2013 07:03 PM
chrislewis
Help! Floor lights and radio stopped working!

So I'm hooking up a subwoofer in my TJ. All was going well until we went to push the head unit back in. The top of the head unit made a small spark, then the radio and floor lights stopped working. I have no idea what the hell happened. I checked all of the fuses behind the glovebox and they were all good. I'm officially stumped. Please save me from this silent torture.

(no power to radio, no power to lights, checked the fuses)

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC