Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 93 YJ engine miss

Join Wrangler Forum Today


Thread: 93 YJ engine miss Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-17-2009 07:04 PM
Rainycity mine just did for the 1st time the other day during a hail storm, missing and jerking etc., scared the heck out of me, thought my daughter and I were walking home. But then it just went away and started running fine again,,I dont have a clue what it may have been, I just blamed the weather,,figured something maybe got wet or something..*LOL*
03-15-2009 02:50 PM
davided thanks. I will try that
03-14-2009 11:04 AM
DezRat Check your vacuum lines. On older jeeps they get brittle and break.
03-14-2009 09:04 AM
Ol' Red Spark plugs? I would do a full tune up and see if that works.
03-13-2009 09:47 PM
davided
93 YJ engine miss

2.5L I4 FI starting out cold...and drive about 1-2 miles, then motor will jerk and almost miss fire but will not stall...will only last for about a mile, and then after that it runs fine. anybody run into this strange behavior ? Im thinking blocked port injectors or dirty fuel filter ???? any suggestions ?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC