Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Someone explain? Auto transmission

Join Wrangler Forum Today


Thread: Someone explain? Auto transmission Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-24-2013 09:28 PM
Bjoye1300 Alright thanks for all the info
02-24-2013 08:22 PM
RednekYJ As long as you weren't revving the piss out of it when it didn't want to move you will b alright.
02-24-2013 07:57 PM
Hardcharger No need to remove trans to replace shield. Maybe starter but not trans
02-24-2013 07:32 PM
Bjoye1300 No I know the trans is still bolted up just the dust shield is cracked and broken off, can it be replaced with out removing the trans from the engine. I did find the culpurate to the leak, a line up front busted so while all the fluid was out I changed the filter and hopefully when I fill it back up everything functions properly.
02-24-2013 04:56 PM
Hardcharger I agree with redneck. Doesn't look unbolted to me either. If you're leaking near the front of the Jeep it's either a cooling line or trans cooler itself that is damaged. Easy way to tell is wash real good let it dry put some fluid in it and crank it up. The pressure will push it out. Fluid is bright red you'll see it
02-24-2013 04:49 PM
RednekYJ I don't think your trans is unbolted. You are however missing the flywheel inspection cover/dust shield. There is no indication of a leak a where? Fluid on the frame/under body is easy to spot
02-24-2013 03:19 PM
Redrider94 There is your problem!! Your transmission has come unbolted from your engine. And you probably lost transmission fluid out of the torque converter. Don't drive it till you get this repaired great damage will be done.
02-24-2013 12:15 PM
Bjoye1300 Ok so I checked the lines and didn't see anything obvious (the lines run out of the driver side of the transmission and up to the radiator correct?) but I did see that the plate thing between the transmission and the engine is cracked anyone know if this could have contributed?
02-23-2013 09:24 PM
sp33dfr33k I agree with Redneck, he's been doin' this stuff for a while...
02-23-2013 09:16 PM
Bjoye1300 I'd been driving for bout an hour but the jeep wasn't very hot and the water was definently way colder but not extremely cold so that could have done it but ill check the lines.
02-23-2013 09:07 PM
RednekYJ Check the lines.
02-23-2013 09:05 PM
sp33dfr33k How cold was the water, and how hot was the jeep, how long had you been drivin'..? Just a thought, not sure but figured id throw it out there..
02-23-2013 09:02 PM
Bjoye1300 Ok any idea y it would fail so suddenly?
02-23-2013 08:52 PM
sinepome
Quote:
Originally Posted by Bjoye1300
So I have a 88 yj with 4.2 and automatic trany. I'm wheelin today and cross through some deep water ( up to the top of the wheels and I have 35s and a a lift so its pretty deep! ) it goes through it like nothin then about 5 min later there's redish pink fluid all over the trail and I've got no movement and end up getting towed. But here's what I don't understand all the fluid leaked out within a few min and from the front kinda near the radiator not near the trany. So does anyone know what happened? I'm kinda ne to jeeps and a little confused.
If it was coming from the radiator area, it was probably the trans fluid cooler(if you have one ). It looks like a small radiator probably in front of actual radiator. Check it for holes or loose/broken lines. GL
02-23-2013 08:47 PM
Bjoye1300
Someone explain? Auto transmission

So I have a 88 yj with 4.2 and automatic trany. I'm wheelin today and cross through some deep water ( up to the top of the wheels and I have 35s and a a lift so its pretty deep! ) it goes through it like nothin then about 5 min later there's redish pink fluid all over the trail and I've got no movement and end up getting towed. But here's what I don't understand all the fluid leaked out within a few min and from the front kinda near the radiator not near the trany. So does anyone know what happened? I'm kinda ne to jeeps and a little confused.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC