Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Build Forum > My 350 build

Join Wrangler Forum Today


Thread: My 350 build Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-03-2014 12:39 PM
CAJUN YJ I've got a tattons shaft on my jeep... I didn't go with a cv style shaft though. I kept the factory style shaft as I didn't c the need for adding a slip yoke eliminator kit. I have no issues at all with vibes an that shaft is pretty dam tough... Running 35" swamper TSL's, TBI 350, an stock ax15. So far so good... An he also said if I was able to twist r break it that he would replace it. Very nice guy to deal with. Found him on eBay.
02-21-2014 05:12 PM
TexasDemon84 Has anyone used this kind of drive shaft? Mine was a little too short, not much about an 1 1/2" or so. So I was thinking of going with this setup.
02-10-2014 10:28 AM
TexasDemon84 Water temp running about 210. That's normal, right? I can adjust it on the electric fan controller.
02-10-2014 12:12 AM
kywaterman glade to hear you got it working
02-08-2014 04:46 PM
TexasDemon84 Well that did it!! Went from intake to bottom hose on heater core and top hose to water pump, then just plugged the other water pump connection.
02-01-2014 04:30 PM
TexasDemon84 Water temperature comes up to normal but no heat from heater. Right now I have both hoses going from pump to heater core. So I'm thinking that I'm putting pressure to both sides of core and just deadheading.
02-01-2014 12:35 AM
kywaterman That is true on some SBC. Not all have a spot on the intake for it. Your water pump is set up for both to come off it. Alot of the older cars (80s) were like that, iirc. My motor is like the way you described, one off intake and one off pump. But then on some they came off the radiator. What exactly is your heater doin?
01-31-2014 07:17 AM
TexasDemon84 I've been told that it's suppose to go from intake manifold to heater core then from heater core to water pump. The smaller hose being the pressure side or inlet and larger hose being the outlet or return. That leaves one water pump connection with nowhere to go.
01-31-2014 04:15 AM
kywaterman Looking at your picture they appear to be connected to the correct things. They both go to heater core. Have you insured there are no air bubbles in the heater core, or that it is not stopped up? I wouldn't think it should matter which one is connected to either inlets on heater core, its pretty much just a small radiator that air is blown across to transfer the heat from the coolant to the air being blown across it. Someone may chime in if I'm wrong here.
01-29-2014 05:11 PM
TexasDemon84 [QUOTE="TexasDemon84;7829945"]Apparently I have hoses going to heater core not hooked up right. My water pump looks like this one. What hoses go where? I know one goes from pump to heater core but which one? And where does the other hose from pump go?
01-29-2014 03:48 PM
TexasDemon84 Apparently I have hoses going to heater core not hooked up right. My water pump looks like this one. What hoses go where?
11-03-2013 10:10 PM
TexasDemon84 Yes, I using stock transfer case I had the tail shaft swapped out on the 700r4 that I'm using.
11-03-2013 10:08 PM
TexasDemon84 Thanks. I used stock Tahoe exhaust but I had to cut y pipe about an inch to make it fit between frame. Then it goes to a stainless Magnaflow with a dump after muffler.
11-03-2013 04:47 PM
1987Wrangler YJ Sweet build! Im doing something similar with a Chevy 327. What is your exhaust?
11-03-2013 03:30 PM
myquite are you running a np231 TC?
11-01-2013 11:45 PM
TexasDemon84 Thank you very much.
10-09-2013 03:21 PM
kywaterman Congrats man, glade to see you got it going
10-07-2013 08:16 PM
CAJUN YJ Congrats on your finished swap!! I'm getting close to being done but not quite there yet!!
Looking very nice!
10-07-2013 08:09 PM
TexasDemon84 Well after a year or so it is done. My 350 swap is done and man does it run great!!
09-25-2013 08:28 PM
WICruiser Thanks for the additional information on the ramhorn manifolds.
09-25-2013 09:04 AM
harleydragon to the best of my knowledge on the factory ramhorns,corvette was the only one to use the 2 1/2 and everything else had smaller..I use the 2 1/2 on mine and then run 2 1/2 inch pipes.You can find them on ebay for about 125 including shipping.You then need a flange and donut.The flanges I use have a 2 5/8 hole and the bolt holes measure 3 inches apart.I carry one of the manifolds to oreillys and match up a donut that has a steel sleeve that taps into the manifold.this holds it in place for easier assembly plus I think it seals better.I then get an exhaust shop to flair me 2 pieces of 2 1/2 inch pipe and build my own exhaust.The exhaust is one of the last things I do so that I can make sure of clearance everywhere.You will be happy with a set of these manifolds for all the reasons I had listed above.When I change a set of headers out I usually have to fight like hell to get them out and then these manifolds just easily fall back in.My wife put the last set in that we changed if that tells you anything...
09-24-2013 10:36 PM
WICruiser Not to hijack this thread but Harleydragon, do you have a preferred source for the ramhorn manifolds? I have seen several variation on E-Bay with one of the variations being the collector diameter. I think 2 1/2" is the biggest and 2 1/4 is the smaller variation. I currently have Sanderson headers that have a 3" collector but before I either make or have made the rest of the exhaust system I need to decide if I am going to stay with them. They are very tight to the block which seems like it would have some advantages but I am concerned that they are to close. Still working on getting the parts that could interfere back in place to get a better handle on it.
09-24-2013 09:37 PM
TexasDemon84 So I take transfer case off to check out transmission fluid leak and as soon as I pull it off I immediately know what the problem is. When you get the transmission to transfer case kit from AA you get this great big seal, well guess who forgot to install said seal onto the adapter. Dang good thing that I had just seen it a couple of days ago.
09-24-2013 08:50 AM
harleydragon
Quote:
Originally Posted by WICruiser View Post
What headers did you use?
I like the ramhorn manifolds that are similar to the stock mid 60's corvette manifolds for several reasons
they flow nearly as good as headers
they fit close and don't cause clearance problems
they don't blow gaskets and leak
temperature under the hood will be cooler than headers
they look clean
I am presently running these on 2 jeeps with 350's.I removed the headers on both to replace them with these and notice no power difference .They did correct clearance problems and drop the under hood temp a lot
09-24-2013 08:36 AM
harleydragon
Quote:
Originally Posted by TexasDemon84 View Post
I'm needing a drive shaft that's about 2 inches longer than stock. 95 Wrangler that had 2.5 five speed. Any driveshafts that will work? Or do I need to have mine redone?
there is a dude on ebay that sells new ones for about 150 bucks
09-24-2013 12:13 AM
TexasDemon84 I'm needing a drive shaft that's about 2 inches longer than stock. 95 Wrangler that had 2.5 five speed. Any driveshafts that will work? Or do I need to have mine redone?
09-24-2013 12:11 AM
TexasDemon84 Stock vortec 350 exhaust headers.
09-23-2013 10:25 PM
WICruiser What headers did you use?
09-22-2013 08:07 PM
TexasDemon84 Thanks, I'll check it out tomorrow.
09-22-2013 07:48 PM
harleydragon sounds like a loose connection somewhere..coil wire or something in the coils circuit would be my first guess..this could include the ground
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:41 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC