Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > California Jeep Forum > The SoCal Clubhouse

Join Wrangler Forum Today


Thread: The SoCal Clubhouse Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Today 11:50 PM
iwaxmyjimmy
Quote:
Originally Posted by Serg5000 View Post
For the most part that's been what's I have been doing. I went to check for spark, I pulled on the wire and it for the metal connecter off. Once I got plugs out they looked a little warn so I got those. I ended up doing wires plugs cap and rotor. It was pretty cheap. I have tested the IAC, MAP, and the fuel regulator. The TPS had a spot when testing it it would show OL. It was supposed to show resistance all the through. The was $29. The throttle body was a little dirty so I pulled it off and cleaned it. Still the issue is there. I'm looking a but further into fuel delivery and fuel pressure. Again. The one thing troubling is the fuel pump. I read it's supposed to stay on for 5 second roughly. It seems to just come on and shut off in about 2 seconds maybe 3. I also jumped out the ballast resistor but that didn't help anything. I guess those were put in to lower the voltage to the fuel pump in order to lower the noise it makes. Anyway. Back at it tomorrow.
The fact it's stumbling at idle I wouldn't think it was the fuel pump, if it was higher in the RPM range I could see it because it needs more fuel there. No vacuum leaks or anything?
Today 11:50 PM
Serg5000 From all the threads I have read. This is a problem that lots of Cherokees have. The bummer is it's always something different that fixes the problem.
Battery. Coil. Fuel pump. Map. IAC. I mean it's never something simple.
Today 11:41 PM
Serg5000
Quote:
Originally Posted by iwaxmyjimmy View Post
Check what you can check and clean what you can clean, try not to replace parts unless you've got solid proof it's a failed part. I would clean the throttle body and also double tap on the IAC. The TPS is a 5volt reference, look up how many volts it should put out at idle and probe the back of the connector with a digital multimeter to make sure it's good.
For the most part that's been what's I have been doing. I went to check for spark, I pulled on the wire and it for the metal connecter off. Once I got plugs out they looked a little warn so I got those. I ended up doing wires plugs cap and rotor. It was pretty cheap. I have tested the IAC, MAP, and the fuel regulator. The TPS had a spot when testing it it would show OL. It was supposed to show resistance all the through. The was $29. The throttle body was a little dirty so I pulled it off and cleaned it.
Still the issue is there. I'm looking a but further into fuel delivery and fuel pressure. Again.

The one thing troubling is the fuel pump. I read it's supposed to stay on for 5 second roughly. It seems to just come on and shut off in about 2 seconds maybe 3. I also jumped out the ballast resistor but that didn't help anything. I guess those were put in to lower the voltage to the fuel pump in order to lower the noise it makes. Anyway. Back at it tomorrow.
Today 11:17 PM
iwaxmyjimmy
Quote:
Originally Posted by Serg5000 View Post
I have not checked the emissions side yet. Also the car does stumble some times when it's just idling on the driveway. I will check the battery tomorrow. The battery is about four months old but I will check it none the less.
Check what you can check and clean what you can clean, try not to replace parts unless you've got solid proof it's a failed part. I would clean the throttle body and also double tap on the IAC. The TPS is a 5volt reference, look up how many volts it should put out at idle and probe the back of the connector with a digital multimeter to make sure it's good.
Today 11:14 PM
Serg5000 I have not checked the emissions side yet.

Also the car does stumble some times when it's just idling on the driveway.

I will check the battery tomorrow. The battery is about four months old but I will check it none the less.
Today 11:08 PM
turdhurdler
Quote:
Originally Posted by Serg5000 View Post
The last two days I have been chasing a ghost that has taken over my daughters 1992 XJ. It started stalling once and a while. When parked and when coming to a stop. No matter what I try I just can't seem to find what's causing the stall. So far I have replaced everything on the ignition side. I did trouble shoot everything first and decided to start replacing old parts. After starting to check the fuel side. The only thing I found was the fuel pressure at the rail. 33 psi. I have read that it's supposed to be around 40+. I'm at a loss for now. Two days of trouble shooting. Tomorrow brings more knuckle busting.
My ex had an XJ with that problem. Turned out to be the battery was on its way out. Not sure why that caused it, but it did. I had replaced the TPS, coil, plugs, wires etc. A friend said to check the battery and that solved the problem. Good luck.

Jeff
Today 11:06 PM
JoeBot13
Quote:
Originally Posted by Serg5000 View Post
The last two days I have been chasing a ghost that has taken over my daughters 1992 XJ. It started stalling once and a while. When parked and when coming to a stop. No matter what I try I just can't seem to find what's causing the stall. So far I have replaced everything on the ignition side. I did trouble shoot everything first and decided to start replacing old parts. After starting to check the fuel side. The only thing I found was the fuel pressure at the rail. 33 psi. I have read that it's supposed to be around 40+. I'm at a loss for now. Two days of trouble shooting. Tomorrow brings more knuckle busting.
Serg have you checked the emissions? Bad O2 sensors or clogged catalytic converter?
Today 11:03 PM
Mad Daddy
Quote:
Originally Posted by WOKNROX View Post
Hey thanx bud...yeah we're having a great time out here...
We have the owner of a Canadian based off road shop camp next to us also...Rock Spyder 4x4 out of Ontario Canada. ...really cool guys...they're giving out all kinds of cool stuff. ..


Good taste in winch
Today 10:51 PM
iwaxmyjimmy
Quote:
Originally Posted by Serg5000 View Post
The last two days I have been chasing a ghost that has taken over my daughters 1992 XJ. It started stalling once and a while. When parked and when coming to a stop. No matter what I try I just can't seem to find what's causing the stall. So far I have replaced everything on the ignition side. I did trouble shoot everything first and decided to start replacing old parts. After starting to check the fuel side. The only thing I found was the fuel pressure at the rail. 33 psi. I have read that it's supposed to be around 40+. I'm at a loss for now. Two days of trouble shooting. Tomorrow brings more knuckle busting.
Does it just stall or does it stumble some times? Any slight misses? Throttle body is all clean mainly the blade and around the edges of it? Idle air control valve maybe needs to be cleaned out?
Today 10:42 PM
Serg5000 The last two days I have been chasing a ghost that has taken over my daughters 1992 XJ. It started stalling once and a while. When parked and when coming to a stop. No matter what I try I just can't seem to find what's causing the stall.

So far I have replaced everything on the ignition side. I did trouble shoot everything first and decided to start replacing old parts. After starting to check the fuel side. The only thing I found was the fuel pressure at the rail. 33 psi. I have read that it's supposed to be around 40+.

I'm at a loss for now. Two days of trouble shooting. Tomorrow brings more knuckle busting.
Today 10:32 PM
Lab Lover
Quote:
Originally Posted by suicideking View Post
Where does the plutonium go? Pretty funky there.



I said DRIVER!

Have fun Steve. I've been watching the Rebel Offroad videos and wishing I was there.
I like when you hear "Other Driver" Lol.....or maybe it's just me that has heard that
Today 10:29 PM
Lab Lover
Quote:
Originally Posted by iwaxmyjimmy View Post
Lmao good one
It would have been better if the guy had a rag in his hand and was washing the belly, lol. Not much else you can do while your down there waiting on help. It looks like he was trying to not get his feet muddy and track dirt into the JK
Today 10:29 PM
suicideking
Quote:
Originally Posted by JoeBot13 View Post
Kinda been done:

Where does the plutonium go? Pretty funky there.

Quote:
Originally Posted by WOKNROX View Post
Here's another one for you guy's. ..This was at the bathtub on Hell'z Revenge. ..
I said DRIVER!

Have fun Steve. I've been watching the Rebel Offroad videos and wishing I was there.
Today 10:08 PM
iwaxmyjimmy
Quote:
Originally Posted by Lab Lover View Post
Looks like it just wanted it's belly scrubbed while in the tub
Lmao good one
Today 10:05 PM
Lab Lover
Quote:
Originally Posted by WOKNROX View Post
Here's another one for you guy's. ..This was at the bathtub on Hell'z Revenge. ..
Looks like it just wanted it's belly scrubbed while in the tub
Today 10:01 PM
iwaxmyjimmy
Quote:
Originally Posted by WOKNROX View Post
Hey thanx bud...yeah we're having a great time out here... We have the owner of a Canadian based off road shop camp next to us also...Rock Spyder 4x4 out of Ontario Canada. ...really cool guys...they're giving out all kinds of cool stuff. ..
Nice maybe in 2016 I'll be able to make it out there lol.
Today 09:48 PM
WOKNROX Here's another one for you guy's. ..This was at the bathtub on Hell'z Revenge. ..
Today 09:44 PM
Zombiehunta666
Quote:
Originally Posted by JoeBot13 View Post
Kinda been done:
Dang it. Thought we had something.
Today 08:16 PM
JoeBot13
Quote:
Originally Posted by WOKNROX View Post
Yeah bud...it sure was. Dale Albright is in the camp site next to me too.
That would make for some good camp fire chat! Should thank him on our behalf for the BRCs work.
Today 08:00 PM
WOKNROX
Quote:
Originally Posted by iwaxmyjimmy View Post
I bet you're having a blast, must be nice to be a civilian enjoying yourself lol
Hey thanx bud...yeah we're having a great time out here...
We have the owner of a Canadian based off road shop camp next to us also...Rock Spyder 4x4 out of Ontario Canada. ...really cool guys...they're giving out all kinds of cool stuff. ..
Today 07:47 PM
iwaxmyjimmy
Quote:
Originally Posted by WOKNROX View Post
Yeah bud...it sure was. Dale Albright is in the camp site next to me too.
I bet you're having a blast, must be nice to be a civilian enjoying yourself lol
Today 07:36 PM
WOKNROX
Quote:
Originally Posted by JoeBot13 View Post
Is that Ian Johnson?
Yeah bud...it sure was.
Dale Albright is in the camp site next to me too.
Today 07:26 PM
JoeBot13
Quote:
Originally Posted by WOKNROX View Post
Hey guys...I just finished running Hell'z Revenge here in Moab and while getting gas for tomorrow's run...look who I ran in to....Ian Johnson from 4x4 Xtreme! and look what he's wheelin! huh!
Is that Ian Johnson?
Today 07:15 PM
WOKNROX Hey guys...I just finished running Hell'z Revenge here in Moab and while getting gas for tomorrow's run...look who I ran in to....Ian Johnson from 4x4 Xtreme!
and look what he's wheelin! huh!
Today 06:30 PM
JoeBot13
Quote:
Originally Posted by Zombiehunta666 View Post
Agreed. We gotta look into this...
Kinda been done:

Today 05:01 PM
Zombiehunta666
Quote:
Originally Posted by suicideking View Post
That might come in handy. Figure if you're stuck in a tight spot and don't have enough room to open the doors. If you have the lambo doors, you could get out. Plus they would stay in place unlike the JK doors that have no spring, just flop in the breeze.
Agreed. We gotta look into this...
Today 04:29 PM
iwaxmyjimmy
Quote:
Originally Posted by HDgasser View Post
Just bought me a lil harbor freight special too... Still learning.
Yeah I ran my first beads when I was 19 they looked like crap then didn't touch a welder again till recently. Been doing little small projects to get some more practice. I enjoy it though. I think it makes your chest hair grow more lol
Today 04:23 PM
HDgasser
Quote:
Originally Posted by iwaxmyjimmy View Post
Heard he can't even weld either

Attachment 989770
Just bought me a lil harbor freight special too... Still learning.

Today 03:34 PM
Lab Lover
Quote:
Originally Posted by suicideking View Post
I guess I'm just past the point in my life where I give a shit what others think. I know lots of people think the 4 door Jeeps are the same as getting a hummer, again could give a rats ass what they think. People hate JK's in general, good for them. Don't buy one.

There's always going to be haters. They will hate anyone different than them. There stuff is better, your stuff sucks.

I don't like lowered civic's with the annoying exhaust. I still smile when I see them all fixed up with the lambo doors. That guy loves his car. Good for him.
Well said. I had to laugh about the last part. Having been involved with the Imports for quite a few years I've seen some messed up cars. Thing is, to the owner they were masterpieces. The hours and money spent on some of those cars would blow your mind.

I will say, Jeepers are truly the most helpful and there aren't near as many haters as in the Import world
Today 03:04 PM
suicideking
Quote:
Originally Posted by Zombiehunta666 View Post
Do you know if they make them for JKUs?
That might come in handy. Figure if you're stuck in a tight spot and don't have enough room to open the doors. If you have the lambo doors, you could get out. Plus they would stay in place unlike the JK doors that have no spring, just flop in the breeze.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:57 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC