Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > need advice, motor ticking

Join Wrangler Forum Today


Thread: need advice, motor ticking Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-13-2013 07:04 PM
CarolinaJeeper could just me time for a tune up (valve clearance adjustment)
03-10-2013 08:37 PM
dangle01 Oh and the oil pressure is normal. I'm the 3rd owner of the jeep I've only had to change the oil once since I had it. The lifters started tapping right before I changed the oil. That was 3 or 4 months ago and it stopped it till now.
03-10-2013 08:24 PM
dangle01 The oil level is good I only run synthetic oil. It doesn't sound like its all the lifters just the back one or two.
03-10-2013 08:16 PM
jokerchief462 Oil level good. Change the oil regularly?? Those are some causes. A good oil using recommended weight for your engine and climate. Try an additive there are many check with your local parts store.
03-10-2013 07:39 PM
dangle01
need advice, motor ticking

i have a 2002 jeep wrangler x, with the 4.0 straight 6. we took it out riding today and after about 2 hours of driving around trails and backroads. it sounded like my lifters started tapping at low rpms and high rpms. but it would also stop tapping at low and high rpms it was random when it started or stopped. when i got home i popped the hood and listened and it sounded like it was coming from the back of the motor. the oil level is good, the oil is fresh and its synthetic. the motor only has 74000 miles on it. any advice is much appreciated. i need to know where to start looking. thanks!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC