Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 1995 YJ grounds...

Join Wrangler Forum Today


Thread: 1995 YJ grounds... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-12-2013 08:41 PM
TonyGreen My problem was definately electrical most likely PCM. The car is running now after following ambushtom's advice on his thread "YJ dies... PCM and Grounding issue" it could also be the fact that I cleaned the fuses and relays in the engine compartment and also the ones underneath the steering wheel.

Thanks
03-11-2013 09:04 PM
TonyGreen
Re: grounds

Quote:
Originally Posted by rebelBullDawg325 View Post
should be a ground that attaches to the bracket for the e-brake pedal. i think it is for the fuel pump or something in the fuel system
Thank you! I will check that.. at this point anything is game.
03-11-2013 08:50 PM
rebelBullDawg325 should be a ground that attaches to the bracket for the e-brake pedal. i think it is for the fuel pump or something in the fuel system
03-11-2013 07:27 PM
TonyGreen alright, thanks. The starter does crank (turn over). Its just that the engine does not start. I think it is a ground cable.

Thanks for the feedback...
03-11-2013 05:34 PM
Garyk I think the rest are frame to body. There might be one from the firewall too. If you have a good ground at the engine and at the frame the starter should spin
03-11-2013 05:22 PM
TonyGreen
1995 YJ grounds...

Hey Everybody!!

My wrangler: 1995 YJ 2.5L 5 Speed

I was wondering which are the grounds that have anything to do with starting the car? As some of you might know, I still haven't been able to start my car. I have checked two grounds the battery ground and the starter/frame ground.

I was told that there are 6, is that true? Also where are they located?

I did research around but have not found a definite answer.

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC