Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Build Forum > Loss of power

Join Wrangler Forum Today


Thread: Loss of power Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-05-2013 10:47 PM
Nasher Mine does the same thing when I go mudding, how can this problem be solved? Just not mudding? Because that would be depressing
03-19-2013 10:11 PM
jokerchief462 Be careful cleaning to much on an old Jeep and it might have more problems.

Yes it will always help to clean up the TBI. So have at it and use something good. Gumout makes a spray that would help. Check the aiirbox and filter too.
03-19-2013 05:10 PM
The Yetti Yeah I figured that out lol, would cleaning out the throttle body help? I'm pretty sure it's not the fuel pump. It was only for like 5 minutes that I lost power in 4th and 5th
03-19-2013 01:15 PM
MTJeepTJ 1990 yj 2.5l is throttle body fuel injection. Not carburated. You would see an injector spraying on throttle body tho. possibly fuel filter or fuel pump for your loss of power.
03-19-2013 12:49 PM
Desert Scorpion let us know if you figure out the problem!
03-18-2013 02:22 PM
The Yetti Regardless if that was the reason for the loss of power that sounds like a good idea anyway, I'm gonna do that this week!
03-18-2013 11:04 AM
Desert Scorpion could be your carb. sometimes dust or mud water gets in it and can clog the vacuum lines in it. look down in your carb wile your car is running and make sure there is steady shots of fuel goin in there. if you can't tell or its not shooting fuel in there correctly put a towel over your carb until your engine almost dies and then remove it quickly. do that a couple of times. what it does is cause pressure in the vacuum lines and then when you remove the towel any dirt or mud is shot out by the pressure. usually works pretty good on my rig. and after i shoot in some carb cleaner to finish any small stuff left in there i notice a pretty good power boost when i take it out for a test run.
03-17-2013 03:19 PM
jokerchief462 Yes Catalytic converter.
03-17-2013 03:17 PM
The Yetti CAT, what is that? You don't mean catalytic converter do you? That's the only thing that came to mind for me lol
03-17-2013 03:02 PM
jokerchief462 Fuel filter, CAT clogging up??? Just a few thoughts.
03-17-2013 02:17 PM
The Yetti
Loss of power

After I went wheelin today my 90 wrangler 2.5L had no power in 4th or 5th gear after but after driving for a minute it gained its power pack, should I be worried?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:45 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC