Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > New Jersey Jeep Forum > installing hid headlights in a 2011 jk

Join Wrangler Forum Today


Thread: installing hid headlights in a 2011 jk Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-26-2013 09:37 AM
Jkwrangler11 Yo guys in another 2 or 3 weeks in going to set up another meet up in Sparta if u guys wana join just keep looking on the reed thAt says north Jersey meet Sparta trails . Lots of people come and it's a blast. If you have any questions just pm me.
03-26-2013 09:35 AM
Jkwrangler11
Quote:
Originally Posted by audi 4A wrangler View Post
What kit did u buy?
I bought a delta fog light set up just for the jk bumper fogs. They are all metal housing heat, water , shock resistant. And they are seriously bright! The color it burns at is 6000k looks like a nice bright white with that perfect tint of blue
03-22-2013 04:34 PM
audi 4A wrangler What kit did u buy?
03-22-2013 12:36 PM
dragons13 I have a relay harness but it dosent have a resistor on it. The harness that goes to the bulb itself had a tiny resistor. I was told I need to get a capacitor to bring the voltage up. It's only cutting out my left bulb and the right side is fine. Minor buzzing noise. Thanks
03-22-2013 01:05 AM
Jkwrangler11 Are you sure you have everything plugged in right? Make sure u do because I had a problem with only one of my lights flickering on mine and the issue was as simple as plugging in one of the wires wrong.
03-21-2013 01:21 PM
VinceCap I have had a problem also. I have a relay and the work fine but the actual hids only work as my high beams not as my regular lights.
03-20-2013 06:01 PM
Jkwrangler11 Do you have a hid relay and resistor wiring harness?
03-20-2013 03:50 PM
dragons13
installing hid headlights in a 2011 jk

having issues installing hid lights into my 2011 jeep jk. they were fine but if i turn car off and start it up an hour later my left headlight goes out and i reset the system by pulling the relay out. plus it buzzes when i use the high beams any help greatly appreciated

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:20 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC