Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Strange Electrical Issue

Join Wrangler Forum Today


Thread: Strange Electrical Issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-25-2013 06:42 PM
AzTJ ^ Good to know, thanks chief.
03-24-2013 11:26 PM
Patrick H The clock spring has nothing to do with wipers, turn signals, hazards, or headlights.

Sounds like you have a faulty multi-function switch.
03-24-2013 11:13 PM
AzTJ The clock spring is behind the steering wheel and warrants renting a puller to remove the wheel. I'm going to try and replace the turn signal stock first... but would like other input.
03-24-2013 11:11 PM
spr0k3t Very unlikely to be both stalks at the same time, I'm thinking it could be the clockspring, just not sure the location of said beast.
03-24-2013 10:57 PM
AzTJ
Strange Electrical Issue

I haven't bee able to delve into it much yet, but when I try to turn on the headlights the wipers go off, same with the turn signals.. but the hazards go as well. Anyone know the root of this?

Is it the clock spring in the column or the turn signal stalk?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC