Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Wont start

Join Wrangler Forum Today


Thread: Wont start Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-20-2009 02:00 PM
Rainycity How many volts are you getting at the battery? 14?
I thought maybe it wasn`t charging properly when I first read your post but I would
not only make sure everything is tight but clean. If you have debris under your grounds you may not be getting a good ground even though everything`s tight.
04-19-2009 08:35 AM
Joey I took the starter back off today. I am going to take it to advanced auto and let them test it and I will let you guys know what I find. Thanks for the advice.
04-19-2009 01:10 AM
87YJWrangler Yeah check for your grounds and than maybe your alternator too
04-18-2009 02:10 PM
jmurray79 remember, it should have a body to chassis ground too.
04-18-2009 01:53 PM
EMS 34 20 X2 bad spot in the starter My XJ did the same thing and the starter was shot
04-18-2009 01:34 PM
Joey Are there any other main grounds besides the one to the block and the fire wall?
04-18-2009 01:20 PM
kik It does sound like a bad ground.
04-18-2009 12:23 PM
Joey Would that make my lights dim and everything too.
04-17-2009 10:45 PM
RednekYJ dead spot in the starter. have someone tap it with a hammer while cranking.
04-17-2009 10:17 PM
Joey
Wont start

I have a 95 Yj with 2.5. All she does when I turn key is click. I checked the voltage at battery, it was good. I moved to the starter, voltage was good. I took the starter off and hooked to jumper cables and it turned over on the floor. Put starter back on and same thing happens. Now I click my lights on and there real dim and my radio clicks off and on. Put new battery terminals on and checked the ground to the block. Every things tight, its about to blow my mind. I think theres a loose ground somewhere. Any ideas. Thanks for the help in advanced.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC