Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Michigan Jeep Forum > More Problems

Join Wrangler Forum Today


Thread: More Problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-01-2013 01:23 PM
sevenservices is it running w/o a thermostat? it should warm up a lot faster and about force you out w the cabin heat on high. Even when I'm running with the top off I can still blast the heat going down the road and it keeps my legs warm.
01-21-2013 05:33 PM
sakicnut I would try a thicker cardboard, that will do wonders
01-20-2013 08:59 PM
wxjeep
More Problems

Though an old trick, I stuff some cardboard in between the grill and the radiator to increase the heat output inside. Seems to work in the colder weather we are now having. Manage to get a whopping 40*F inside my Jeep. Though I can still feel the cold wind blow through with the gusty winds we had today. That'w with a hard top.

As to the new problem I'm facing, the windshield wiper never did work on high. Now today after topping off the tank with the idea of maybe driving that to work tomorrow as they are forecasting up to a foot or more snow along I-194 to Holland. The low speed on my wiper motor kept going slower and slower till it stopped. Can't afford that this week, got to make the loan payment.

I feel like for getting this vehicle.

Maybe someday I'll get'r fixed, maybe.......

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC