Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 95 YJ trouble starting

Join Wrangler Forum Today


Thread: 95 YJ trouble starting Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-21-2009 11:06 PM
JoshD321 Thank you I think Im going to try the fuel pump relay then the ignition module Im off tomorrow so ill have a little time.
04-21-2009 07:03 PM
dooder im new to jeeps so taking a shot at saying maybe a bad fuel pump relay or even an ignition module if it controls the fuel pump relay. Even a bad ground can cause weird crap to happen. Ofcourse after saying that itll probably be a fuel pump is bad.
04-21-2009 02:21 PM
scrambler1 fuel pump is in your tank.
04-21-2009 11:48 AM
JoshD321
95 YJ trouble starting

Ok I just bought this wrangler 5 days ago. It has a rebuilt motor in it and when I first test drove it it started up fine everytime. Well now that I got it home and let it sit over night or at least an hour, it takes forever to start. I searched past threads and found many suggestions. I tried changing spark plugs and still does it. I have finally noticed that when I turn the key to the on position before I crank it, the fuel pump doesn't come on along with the bulb check. After turning the key over and over it will finally come on and I hear the fuel pump working. I was wondering if anyone had the same problem or know what to do in this instence. I think either bad ground on fuel pump or short. Also how to get to fuel pump would be nice to know also, thank you

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:14 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC