Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > ignition switch issue

Join Wrangler Forum Today


Thread: ignition switch issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-04-2013 04:31 PM
wounderwhy hey i got, connection on battery terminal good. connection to main fuse block bad, cleaned and replaced. jeep running like a top!
04-04-2013 07:58 AM
wounderwhy
ignition switch issue

I have spent the whole day yesterday reading on different forums about these ignition switch issues. I have a different problem and am looking for a cure. Oh yea this is my first jeep and i have had it about a month. She is an 05 wrangler unlimited 6 speed manual. my problem is sometimes when i turn the key to on, i get nothing at all no lights no beeps no nothing, if i leave it in the on position for about 30 secs everything lights up i can start it and go. the only thing i have noticed that happens when its dead it will reset the clock on the radio. I have already checked the battery and ground on the engine. have not been in the mud cause its all still snow covered. I hope someone has had similar problems, and will tell me what i need! Thanks in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC