Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > Ohio Jeep Forum > Jeep trouble

Join Wrangler Forum Today


Thread: Jeep trouble Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-28-2013 09:21 AM
Dawn10 Oh my gosh that is horrible! I smelled something thats why I checked mine and barely anything on dipstick so I just check it every 2 wks. Mine's an 08 with same mileage as yours. I drive mine to beach every yr too! I am so sorry for you!
04-25-2013 10:02 PM
2JeepsThatRun What are the warranties like on the new jeeps? If your still under warranty I would get everything I could for that.
04-25-2013 09:56 PM
DirtyDiva Definitely keep an eye on it. I had my oil changed less than 2k ago and when I was driving yesterday, the engine started clicking. Took it in today and was told my engine is bye-bye. I had apparently been driving with 0 oil.

I have read so many stories of this excessive oil consumption and wish I knew before. There was no warning, no bad smell, no smoke. For an '07 JK with 40000 miles, it's ridiculous and I'm furious. I'd hate to see anyone else face this. It's my 3rd Jeep and I've never had to deal with crap like this.
04-22-2013 09:00 PM
Dawn10 Well I got an oil change and all 4 guys had something different to say about the oil. One said his dad has the same engine and has the same problem, another guy said it was the oil they put in burns up fast and the other guy said Jeeps go through oil like that and i could come in when it's low and it's free. Yet when it was all said and done it came to $70! I said what! Is it because I'm a chick! Well you could use a new filter and I took $5 off! I even had a coupon for $10 off. Geez...... I guess they see blonde and take my money.
04-20-2013 01:31 AM
upin1212
Quote:
Originally Posted by JGreen06TJ View Post
Several letters in JP Magazine talking about excessive oil use in the JKs. Had a letter this month that said they used SeaFoam motor treatment and havent had the problem again. Good luck. Keep an eye on it. I've had vehicles in the past that used lots of oil. I kept several quarts in the trunk and topped off monthly.
I have heard nothing good about sea foam.
04-19-2013 10:24 PM
JGreen06TJ Several letters in JP Magazine talking about excessive oil use in the JKs. Had a letter this month that said they used SeaFoam motor treatment and havent had the problem again. Good luck. Keep an eye on it. I've had vehicles in the past that used lots of oil. I kept several quarts in the trunk and topped off monthly.
04-15-2013 06:49 AM
Dawn10 I thought the same thing about well if it breaks down I'll know then. The oil thing scares me so may have to find someone to check it out. Surely don't want to drive it to the beach 12 hrs and it break down on me this summer... ugh!
04-15-2013 12:41 AM
upin1212
Quote:
Originally Posted by Dawn10 View Post
So my Jeep runs low on oil way before it's due for another oil change. I have to check it and pour some in about every 4 wks. This last time you could barely see oil on dipstick. Shit, I could have blown the engine up. Is this normal for Jeeps to use so much oil? Also, If Im sitting at a light, put it in neutral theres a loud clicking noise but when I put the clutch in you dont hear it. Help!
I had a 02 sport once and had same noise and if I put it in 4wd it also stopped. It's a jeep the transfer case was just noisy got louder after it got hot. I changed gear oil and all that fun stuff still had it. I figured oh well if it breaks ill know what it is. As for oil that's not the norm.
04-14-2013 08:23 PM
Dawn10 Neither... hmmm what to do
04-06-2013 05:52 PM
sirchadley do you have any drips under it after it sits? have someone start it while you look at the tail pipe to see if there is any blue smoke. not real sure about the clutch issue. maybe a throw out bearing going out but not real sure.
04-05-2013 12:14 PM
Dawn10
Jeep trouble

So my Jeep runs low on oil way before it's due for another oil change. I have to check it and pour some in about every 4 wks. This last time you could barely see oil on dipstick. Shit, I could have blown the engine up. Is this normal for Jeeps to use so much oil? Also, If Im sitting at a light, put it in neutral theres a loud clicking noise but when I put the clutch in you dont hear it. Help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC