Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > engine temp issue

Join Wrangler Forum Today


Thread: engine temp issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-08-2013 07:23 PM
Dillon84 ok i was thinking that but wasn't sure seeing ive never had a stat do that to me before
04-08-2013 07:17 PM
Defcon 1 The thermostat is suspect. It's possible it's not opening under low engine idle speeds/pressures. When you're moving the airflow helps keep the engine cooler too, but start with the T-stat they're real cheap and easy to R&R.

Other possible causes could be inadequate coolant/reservoir level, (also easy to correct), fan clutch lock-up, water-pump lock up.

-Do Not- let the temperature get redline under any circumstances, if it goes about 230 again it didn't fix it, shut it down immediately. Even the slightest amount of over-temp can wear the engine components out.
04-08-2013 06:34 PM
Dillon84
engine temp issue

hey everyone this is a new one on me, i was sitting in the old girl letting her idle for a bout 10 minutes whe i noticed my temp gage past red line but no noticeable affects. naturally i freak and shut her down but when i fired back up the needle marched back to red line so i tried to start for home. well as soon as i was moving she dropped back down below half way and as long as i was moving thats where it stayed till i stopped or slowed way down, when i did she started climbing again. what is it? please help?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:38 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC