Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Opinion, tranny pt t case seal failure (pics included)

Join Wrangler Forum Today


Thread: Opinion, tranny pt t case seal failure (pics included) Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-13-2013 09:33 AM
RepairMan Does it smell and look like ATF or trans lube? When mine looked like that it was the trans output seal. It's between the trans and xfercase. Knowing which fluid is leaking is the key to the puzzle.
04-13-2013 05:02 AM
BreckenridgeYJ Thank you for your thoughts. It's equally wet on each side. I know it's a toss up. As is finding a place to wrench on it. Thought I'd try the long shot. I will update progress, but please update experience. Thank you
04-12-2013 05:12 AM
jimmy_buckle Take the skid plate off to get a better look/better photos to give people a better chance of diagnosing the seal??
04-12-2013 02:15 AM
BreckenridgeYJ Edit: * tranny or t case. Thank you ipad auto correct *

Condo association rules and blizzards in Colorado have kept me from tearing into this. Thought I'd get opinions of which seal is most likely the culprit and pick it up when I'm in town (then cross my fingers)...

98 tj, 4.0' ax-15.... Doesn't drip when parked... Seems to only leak when driving and started after a Moab trip.... Hasn't seen more than 5 miles of driving since I noticed it.

I've seen similar threads, but no one ever seems to close them up with the final diagnosis.



Attachment 235123



Attachment 235124



Attachment 235125



Attachment 235126

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC