Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > Right side speaker issue.

Join Wrangler Forum Today


Thread: Right side speaker issue. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-13-2013 09:41 PM
woansleftpeg It's always the last thing you check...... at least you have a shiny new stereo now.
04-13-2013 09:30 PM
Crazefaze It was as easy as replacing the stereo. I feel stupid because I rewired the entire jeep before I realized it was the stereo all along.
04-13-2013 04:38 PM
woansleftpeg I would do the following:

- Remove right side sound bar speaker
- Wire it directly to one of the right side pairs in the back of the HU
- Test whether it works
- Wire it directly to the other right side pair
- Test whether it works
- Wire it directly to one of the left side pairs
- Test whether it works

If it works in all cases, the issue is in the car wiring.
If it works in none of the cases, the issue is with the speaker. (I doubt that, given you've changed them.)
If it works on the left and not on the right, the issue is in your head unit.

Then you'll know what to replace.
04-13-2013 03:08 PM
Crazefaze


It's the wires on the right side. Purple and light blue/black that are receiving power.
04-13-2013 03:00 PM
Crazefaze
Still nothing.

So it's been a while since I've worked on this problem and now that I've torn the whole jeep apart I still can't find the issue. I replaced every speaker. I put new fuses in. I rewired the soundbar and used one of those electic light tester to test current and all I can tell for sure is that no power is being supplied to any of the right sided speakers. The wiring path is the same as the other speakers but only the ones applied to the right side don't recieve power. I think I may go get a new stereo and see if that solves the problem. I'm at a loss for what it could be.
09-21-2012 07:29 AM
kbar1333 I am having the same problem. The top and doors are off and I usually keep my Jeep in the garage but last night I left it out. It was damp this morning because of the morning dew and all of the speakers worked at first. As I was pulling into work all of the right side speakers stopped working. I was thinking a fuse but that would probably cause the the stereo and all speakers not to work? Could it be the dampness and hopefully when it dries out it will work? Crazefaze, were you able to figure out your issue?
08-03-2012 02:15 AM
BossierCity_WranglerJK Loose connections between radio and left side speakers. Or something in the stock headunit is fried. I just got threw re wiring my entire aftermarket amp because it stopped working, still didn't fix it, took the amp to a audio store turned out water/moisture fried it. Even though this has nothing to do with your issue, electronics are tricky. It could be a lot of issues I am going to assume that there is a short in the radio somewhere between the radio and speakers.

Try checking the wires out from the head unit to speakers and make sure there all connected.

I can tell you though it isn't the speakers since there new lol.

I'm not to sure about the fuses because I am pretty sure if it was a fuse the whole radio wouldn't work. Not just one side.
08-03-2012 02:07 AM
Crazefaze
Right side speaker issue.

So I'm sort of new to this, but I'm having some issues with my speakers. The speakers on the passengers side, both in the sound bar and in the dash are not working. I rained into the Jeep a bit ago and it worked for a few minutes and then just died out(static and then gone). I'm not really sure what's causing the problem though.

I bought new speakers for the sound bar and that didn't fix the problem, so I can assume it's not the speaker. I can't tell if it's a wiring issue or whether it'd be a fuse (but the drivers side speakers work). I pulled out the stereo and checked if all the wires were plugged in properly and not wet and that didn't do anything. It's been a couple weeks since they stopped working and I'm sure everything is totally dry by now. I'm probably going to take apart the sound bar next and see if there's anything wrong with the wires but the problem is I have no idea what I'm doing. The wiring job is pretty shitty though, I'm thinking about just re-wiring my whole stereo system.


Not sure what else there is to do. Any thoughts?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:18 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC