Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > WF Local > WF Local Forums for Your Region and State > California Jeep Forum > Diagnostic problem HELP

Join Wrangler Forum Today


Thread: Diagnostic problem HELP Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-17-2013 10:39 PM
JPi1
Quote:
Originally Posted by Idriveoverstuff View Post

Honestly not sure i have been looking at then and they look fine but tomorrow ill jack it up and take the weight off and take a gander..
Also, if you have the factory driveshafts, check for any damage at the spline area. This will cause a vibration and squeak too.
04-17-2013 10:36 PM
Idriveoverstuff
Quote:
Originally Posted by JPi1

Look at your front axle u joints real close, look for fresh bare metal around the joints. Did the squeak and vib start At the same time?
Honestly not sure i have been looking at then and they look fine but tomorrow ill jack it up and take the weight off and take a gander..
04-17-2013 10:10 PM
JPi1
Quote:
Originally Posted by Idriveoverstuff View Post
Vibration about 60mph and not a solid squeak but a squeal squeak squeak when I let off the peddle/ braking ...
Ideas?
Look at your front axle u joints real close, look for fresh bare metal around the joints. Did the squeak and vib start At the same time?
04-17-2013 10:00 PM
Jk4thedirt They say that if you lift your jeep more than 2.5" you have to replace the front drive shaft. I'm running 5.0" and still running my stock one. I know it's going to give up the ghost soon. I figure its a 2013 JKUR with 10k miles. I should be ok another month. After that, I will look into replacing the front drive shaft.
You didn't say anything about the steering stabilizer nut coming off. I was trying to figure out why you are getting a noise at 60 mph on the freeway. You wouldn't get that noise at 60 on the freeway with a rock in your breaks. That only happens when your going slow.
04-17-2013 09:53 PM
Idriveoverstuff The underside of my rubi looks like it had fun on a slip n slide lined with cheese graders haha to put it that way
04-17-2013 09:52 PM
Idriveoverstuff Ok so what do I do hmm you think it mite be a drive link in the front? A rock in the brakes? Can I still when this weekend? My stabilizer bolt flew off yesterday and it kinda stopped I put a new one on and it really stopped and the vibration is at a minimum and the sound is at a minimum or sometimes aswell
04-17-2013 09:27 PM
Jk4thedirt No they are not. It's jeeps way of keeping the mall cruzers happy and maintenance free.
04-17-2013 09:20 PM
Idriveoverstuff It looks crazy! Are the jkru drive shafts not serviceable? I have been working on cars and trucks my whole life but this is my first real jeep.
04-17-2013 09:14 PM
Jk4thedirt Then my guess is driveshaft. You can check it pretty easy. Take out the front drive shaft and take it out for a drive. You won't hurt anything running around without one. Time to start the process of elimination game.
04-17-2013 09:07 PM
Idriveoverstuff
Quote:
Originally Posted by Jk4thedirt
Depending on your wheeling habits, it could be the front driveshaft. How big of lift are you running? And how often do you go wheeling and how hard do you wheel?
3.5 rubicon express, 35s lately it's been John Bull, calico and as hard as I can go ha
04-17-2013 09:36 AM
Jk4thedirt Depending on your wheeling habits, it could be the front driveshaft. How big of lift are you running? And how often do you go wheeling and how hard do you wheel?
04-17-2013 02:43 AM
Idriveoverstuff
Quote:
Originally Posted by Jk4thedirt
It could be a drive shaft. Is the noise coming from the front or rear?
Can't tell but sounds like front driver... Everything looks good tho, can't figure it out but I'm going to hungry valley this weekend ready or not I'm just hoping to figure it out and fix it before I find out the hard way ha
04-16-2013 09:13 PM
Jk4thedirt It could be a drive shaft. Is the noise coming from the front or rear?
04-16-2013 08:40 PM
Idriveoverstuff
Diagnostic problem HELP

Vibration about 60mph and not a solid squeak but a squeal squeak squeak when I let off the peddle/ braking ...
Ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:39 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC