Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Connected battery wrong

Join Wrangler Forum Today


Thread: Connected battery wrong Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-22-2013 10:58 AM
theYeti Will do, hopefully it's not that though
04-21-2013 10:53 PM
jk'n If you don't know what a diode is then my advice would be to have it looked at by a technician. Isn't worth having it serviced? Get a new one.
04-21-2013 09:33 PM
theYeti What's a dido? I've never dealt with electrical problems lol
04-21-2013 08:25 PM
jk'n If the radio still doesn't work after replacing fuses, there is generally a diode across the incoming line for just this occasion to protect the radio components. That diode will conduct heavily on reverse polarity usually taking out the fuse before shorting the diode. If however you power up the radio and it takes out the new fuse, you will likely have to replace the diode.
04-21-2013 08:03 PM
goin camping Been there and done that.

Check your fuses and I'll bet you'll find a couple of fried ones. That should be the only damage.
04-21-2013 07:42 PM
theYeti
Connected battery wrong

Was putting on new fenders and when reconnecting the battery I had the battery turned around from previous position, didn't pay attention and connected it wrong like a dumbass. Now the voltage meter is reading low and my radio doesn't work. Does anyone know what I did? I figured something like that would result but didn't expect the radio to be gone. Did I screw my alternator?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC