Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Finally finished my lift!And some questions..

Join Wrangler Forum Today


Thread: Finally finished my lift!And some questions.. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-23-2013 01:27 AM
Grizzlycb It makes the sound in gear out of gear clutch in or out. But when going slower no noise. I replaced the drive shaft u joint in the back a few weeks ago. I'm hoping the t case drop will stop it. Ill put it on in a week when I get more days off. I'm hoping that's the problem
04-22-2013 01:59 PM
Charley24 It makes the sound when the clutch is in and/or when in neutral? When in gear with the clutch out it doesn't make the sound?
04-22-2013 01:20 PM
sevenservices good job on the install, man what a difference. Looks good!

For the sound, you may have a bad u joint that wasn't to bad with the previous angle but is not happy at the new angle. Check those first... Aside from that its really hard to tell without hearing it in there. Wish MI and KY wern't so far apart lol.
04-22-2013 04:50 AM
Grizzlycb Well my before during and after pictures got scrambled around (iPhone app) but I'm sure y'all can figure it out. Now to my question after driving it around in high speeds my tranny makes almost a grinding sound or something sounds like its right under the stick its self. That's when it's in neutral or the clutch is in.. It runs and drives fine just makes that weird sound any suggestions? Oh and it don't do it when it's slow just at like 25 or faster the faster I'm going the more it makes the sound ?
04-22-2013 04:46 AM
Grizzlycb
Finally finished my lift!And some questions..

So I finally finished my rc lift I did 1inch rc shackles and 2.5 rc lift.
Before


Attachment 239385

During

Attachment 239389




Attachment 239389


Attachment 239390

After

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC