Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Front ball joints

Join Wrangler Forum Today


Thread: Front ball joints Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-23-2013 08:31 PM
05ljman
Quote:
Originally Posted by apaTJ View Post
Grab the front driveshaft while in 2wd and twist it to check for any play. If there is much look at both axle ujoints and you'll be able to tell which one it is if ones bad.
You mean while the truck is turned on or off. The way you said "while its in 2 wheel drive makes me think the truck should be running. I don't imagine that's what you mean tho
04-23-2013 01:19 AM
apaTJ Grab the front driveshaft while in 2wd and twist it to check for any play. If there is much look at both axle ujoints and you'll be able to tell which one it is if ones bad.
04-22-2013 11:14 PM
05ljman
Quote:
Originally Posted by kyjeep View Post
More likely an axle U joint problem.
Are you talking about the u joints in the hub, near the wheel? (towards the end of the axle) If so, is there any way, besides removing the u joint, to tell that the part has worn out? Like can I turn the wheel and drive slowly while having a buddy look at the u joint? Thanks for the help
04-22-2013 11:11 PM
05ljman
Quote:
Originally Posted by jeepwayoflife View Post
Were you turning with the jeep in 4wd on pavement? If so, you could have damaged something (likely the front axle ujoints) because of the bind. Are you sure there is no automatic locker in the front? Many will click when turning as they allow the axle shafts to move at different speeds.

The ujoints are most likely, but could it be something with your steering gear box or pump? You started another thread about it being rough after wheeling one day. Maybe damage occurred?
Nope I know thats a real bad idea. I should have been more specific sorry. When in 4wd, I had the Jeep in like wet muddy sand.
04-22-2013 11:10 PM
05ljman
Quote:
Originally Posted by jkmohican View Post
It won't be a locker because auto lockers don't click when in 4wd, plus you'll KNOW when you have a locker. Let me know what happens, Jake.
Sure thing Wissam, after all, this problem is the reason I'm riding shotgun with you at Bundy!!
04-21-2013 05:35 PM
jkmohican
Quote:
Originally Posted by Mulvihill64 View Post
Sounds like an auto locker to me. I would check the front diff for a locker.
It won't be a locker because auto lockers don't click when in 4wd, plus you'll KNOW when you have a locker. Let me know what happens, Jake.
04-21-2013 01:16 PM
Mulvihill64 Sounds like an auto locker to me. I would check the front diff for a locker.
04-21-2013 12:43 PM
jeepwayoflife Were you turning with the jeep in 4wd on pavement? If so, you could have damaged something (likely the front axle ujoints) because of the bind. Are you sure there is no automatic locker in the front? Many will click when turning as they allow the axle shafts to move at different speeds.

The ujoints are most likely, but could it be something with your steering gear box or pump? You started another thread about it being rough after wheeling one day. Maybe damage occurred?
04-21-2013 11:35 AM
kyjeep More likely an axle U joint problem.
04-21-2013 11:25 AM
05ljman
Front ball joints

Hi guys. I have an issue. When I'm driving in like a straight line or in normal 2wd, I don't have an issue, or at least don't hear one. But when I turn the wheel all the way, even in 2wd, I hear a clicking noise. This problem only gets worse when the jeep is in 4wd. Is it the ball joint? Can I go wheeling with it like this? (I haven't yet). Thanks for any help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC